summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordobo902015-06-08 19:32:47 +0200
committerdobo902015-06-08 19:32:47 +0200
commit74ca0beab4a6caa72bc6e360fa6e8f2b6409b18c (patch)
tree06edbc261cb52eec8ef1c37e25c4ca48ee793c2a
downloadaur-scurve.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
-rw-r--r--pillow.patch36
-rw-r--r--progress.patch8
5 files changed, 120 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..d8e3c1fec7a5
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = scurve
+ pkgdesc = A collection of algorithms and visualisation tools related to space-filling curves.
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/cortesi/scurve
+ arch = any
+ license = custom:unknown
+ makedepends = python2-setuptools
+ depends = python2-pillow
+ depends = python2-cairo
+ source = https://pypi.python.org/packages/source/s/scurve/scurve-0.2.tar.gz
+ source = pillow.patch
+ source = progress.patch
+
+pkgname = scurve
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fadc111b358b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = scurve
+ pkgdesc = A collection of algorithms and visualisation tools related to space-filling curves.
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/cortesi/scurve
+ arch = any
+ license = custom:unknown
+ makedepends = python2-setuptools
+ depends = python2-pillow
+ depends = python2-cairo
+ source = https://pypi.python.org/packages/source/s/scurve/scurve-0.2.tar.gz
+ source = pillow.patch
+ source = progress.patch
+ md5sums = 6bfbb91c6666df71f039476f16412898
+ md5sums = 51cd947d8d9eed281b4533b942c7941a
+ md5sums = 22a492d2f22e9d680751fe7c36ba6792
+
+pkgname = scurve
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d396d9a88eca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Dobroslaw Kijowski [dobo] <dobo90_at_gmail.com>
+
+pkgname=scurve
+pkgver=0.2
+pkgrel=1
+pkgdesc='A collection of algorithms and visualisation tools related to space-filling curves.'
+arch=(any)
+url=https://github.com/cortesi/scurve
+license=('custom:unknown')
+depends=(python2-pillow python2-cairo)
+makedepends=(python2-setuptools)
+source=(https://pypi.python.org/packages/source/s/scurve/${pkgname}-${pkgver}.tar.gz
+ pillow.patch
+ progress.patch)
+md5sums=(6bfbb91c6666df71f039476f16412898
+ 51cd947d8d9eed281b4533b942c7941a
+ 22a492d2f22e9d680751fe7c36ba6792)
+
+prepare() {
+ cd ${srcdir}
+ patch -p0 < pillow.patch
+ patch -p0 < progress.patch
+
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ msg2 'Replacing python shebang by python2 shebang...'
+ find . -type f -exec sed -i \
+ -e '1s|^#!/usr/bin/env python$|#!/usr/bin/env python2|' \
+ -e '1s|^#!/usr/bin/python$|#!/usr/bin/env python2|' \
+ "{}" \;
+}
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python2 setup.py install --root=${pkgdir} --optimize=1
+}
diff --git a/pillow.patch b/pillow.patch
new file mode 100644
index 000000000000..ba885434e1f6
--- /dev/null
+++ b/pillow.patch
@@ -0,0 +1,36 @@
+diff -rupN scurve-0.2/binvis scurvep/binvis
+--- scurve-0.2/binvis 2014-07-10 01:25:26.333477204 +0200
++++ scurvep-0.2/binvis 2014-07-10 01:31:54.662815913 +0200
+@@ -2,7 +2,7 @@
+ import os.path, math, string, sys
+ import scurve
+ from scurve import progress, utils, draw
+-import Image, ImageDraw
++from PIL import Image, ImageDraw
+
+
+ class _Color:
+diff -rupN scurve-0.2/colormap scurvep/colormap
+--- scurve-0.2/colormap 2014-07-10 01:25:26.433478743 +0200
++++ scurvep-0.2/colormap 2014-07-10 01:32:20.116543018 +0200
+@@ -2,7 +2,7 @@
+ import os.path, math
+ import scurve
+ from scurve import progress
+-import Image, ImageDraw
++from PIL import Image, ImageDraw
+
+ def sortedPixels(csource, img, quiet):
+ img = Image.open(img, "r")
+diff -rupN scurve-0.2/testpattern scurvep/testpattern
+--- scurve-0.2/testpattern 2014-07-10 01:25:26.346810714 +0200
++++ scurvep-0.2/testpattern 2014-07-10 01:32:28.383337383 +0200
+@@ -2,7 +2,7 @@
+ import os.path, math
+ import scurve
+ from scurve import progress
+-import Image, ImageDraw
++from PIL import Image, ImageDraw
+
+
+ def drawmap(map, csource, name, quiet):
diff --git a/progress.patch b/progress.patch
new file mode 100644
index 000000000000..c703f3c0d7c2
--- /dev/null
+++ b/progress.patch
@@ -0,0 +1,8 @@
+diff -rupN scurve-0.2/scurve/progress.py scurvep/scurve/progress.py
+--- scurve-0.2/scurve/progress.py 2014-07-10 01:35:46.126395423 +0200
++++ scurvep-0.2/scurve/progress.py 2014-07-10 01:39:39.260000746 +0200
+@@ -1,4 +1,3 @@
+-#!/usr/local/bin/python
+ import sys, time, math, datetime
+
+ class Inplace: