summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Krivopalov2018-07-18 19:56:22 -0700
committerVladimir Krivopalov2018-07-18 19:56:22 -0700
commit86b94588a2371be28ca9bf4664895d9d4f001cd0 (patch)
tree31e0c10567a83c671e36bc3ed4af3a48c27be259
parent6f7fa719d924bde7d12e72f81402ce77dc24ea6b (diff)
downloadaur-scylla.tar.gz
Use gcc7
Signed-off-by: Vladimir Krivopalov <vladimir.krivopalov@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12135aa32398..ea307a9ee792 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,8 @@ pkgbase = scylla
arch = x86_64
license = AGPL
makedepends = git
+ makedepends = gcc7
+ makedepends = gcc7-libs
makedepends = antlr3-cpp-headers-git
makedepends = libyaml
makedepends = yaml-cpp
diff --git a/PKGBUILD b/PKGBUILD
index a72d54e2e6e6..1fe3c25289b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ depends=('hwloc' 'systemd' 'collectd' 'python-yaml' 'python2-yaml' 'python-urwid
optdepends=('scylla-jmx: JMX interface for compatibility with tooling such as nodetool'
'scylla-tools: Tools to be used with ScyllaDB, such as cqlsh, nodetool and others')
-makedepends=('git' 'antlr3-cpp-headers-git' 'libyaml' 'yaml-cpp'
+makedepends=('git' 'gcc7' 'gcc7-libs' 'antlr3-cpp-headers-git' 'libyaml' 'yaml-cpp'
'lz4' 'zlib' 'snappy' 'jsoncpp' 'gnutls' 'ninja'
'ragel' 'libaio' 'crypto++' 'xfsprogs' 'jre8-openjdk-headless'
'numactl' 'libpciaccess' 'libxml2' 'thrift-0.10.0' 'lksctp-tools'
@@ -58,7 +58,7 @@ build() {
cd "$srcdir/${pkgname}"
sed -i -e 's@sizeof(byte)@sizeof(CryptoPP::byte)@g' md5_hasher.hh repair/repair.cc
sed -i -e 's@reinterpret_cast<const byte@reinterpret_cast<const CryptoPP::byte@g' md5_hasher.hh repair/repair.cc
- ./configure.py --mode=release
+ ./configure.py --mode=release --c-compiler=gcc-7 --compiler=g++-7
JOBS=`nproc --all`
# It turns out that on maximum jobs compiler often runs out of memory and crashes
# Let's be conservative and assign only half of the available CPU threads