summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Mehren2018-04-05 14:36:40 +0200
committerDavid Mehren2018-04-05 14:38:41 +0200
commit75a24707f2e48718cc0c38a17f738b730bb6518a (patch)
tree3b35e53f8296b9e2417a5609bf37177c7702a07b
parentacf74865191496d2be7587902e6887f882e12062 (diff)
downloadaur-75a24707f2e48718cc0c38a17f738b730bb6518a.tar.gz
Update for new SDAPS with Python 3
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD40
2 files changed, 37 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a9515fa359c..b80dba287975 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,33 @@
pkgbase = sdaps-git
pkgdesc = Scripts for data acquisition with paper based surveys
- pkgver = r927.d91e982
+ pkgver = r980.cd1d872
pkgrel = 1
url = https://github.com/sdaps/sdaps
arch = any
license = GPL3
license = LPPLv1.3c+
checkdepends = opencv
- checkdepends = python2-gobject
- checkdepends = python2-poppler
+ checkdepends = poppler-glib
checkdepends = hdf5
- checkdepends = python2-numpy
+ checkdepends = gtkglext
+ checkdepends = python-gobject
+ checkdepends = python-numpy
checkdepends = texlive-science
makedepends = git
- makedepends = python2-distutils-extra
+ makedepends = python-distutils-extra
makedepends = libtiff
- depends = python2-cairo
+ depends = python-cairo
depends = texlive-latexextra
depends = texlive-pictures
depends = zbar
- depends = python2-reportlab
+ depends = python-reportlab
depends = pdftk
- depends = python2-pdftools
optdepends = opencv: Import of other image formats (convert, add --convert)
- optdepends = python2-gobject: Import of other image formats (convert, add --convert)
- optdepends = python2-poppler: Import of other image formats (convert, add --convert)
+ optdepends = poppler-glib: Import of other image formats (convert, add --convert)
optdepends = hdf5: Import of other image formats (convert, add --convert)
- optdepends = python2-numpy: Import of other image formats (convert, add --convert)
+ optdepends = gtkglext: Import of other image formats (convert, add --convert)
+ optdepends = python-numpy: Import of other image formats (convert, add --convert)
+ optdepends = python-gobject: Import of other image formats (convert, add --convert)
source = git+https://github.com/sdaps/sdaps.git
source = git+https://github.com/sdaps/sdaps-class.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 216e7652fce3..d2e7e62bdf2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,28 @@
# Maintainer: David Mehren <david.mehren@udo.edu>
pkgname=sdaps-git
-pkgver=r927.d91e982
+pkgver=r980.cd1d872
pkgrel=1
pkgdesc="Scripts for data acquisition with paper based surveys"
arch=('any')
url="https://github.com/sdaps/sdaps"
license=('GPL3' 'LPPLv1.3c+')
-depends=('python2-cairo' 'texlive-latexextra' 'texlive-pictures' 'zbar' 'python2-reportlab' 'pdftk' 'python2-pdftools')
-makedepends=('git' 'python2-distutils-extra' 'libtiff')
+depends=('python-cairo' 'texlive-latexextra' 'texlive-pictures' 'zbar' 'python-reportlab' 'pdftk')
+makedepends=('git' 'python-distutils-extra' 'libtiff')
optdepends=('opencv: Import of other image formats (convert, add --convert)'
- 'python2-gobject: Import of other image formats (convert, add --convert)'
- 'python2-poppler: Import of other image formats (convert, add --convert)'
+ 'poppler-glib: Import of other image formats (convert, add --convert)'
'hdf5: Import of other image formats (convert, add --convert)'
- 'python2-numpy: Import of other image formats (convert, add --convert)'
+ 'gtkglext: Import of other image formats (convert, add --convert)'
+ 'python-numpy: Import of other image formats (convert, add --convert)'
+ 'python-gobject: Import of other image formats (convert, add --convert)'
+)
+checkdepends=('opencv'
+ 'poppler-glib'
+ 'hdf5'
+ 'gtkglext'
+ 'python-gobject'
+ 'python-numpy'
+ 'texlive-science'
)
-checkdepends=('opencv' 'python2-gobject' 'python2-poppler' 'hdf5' 'python2-numpy' 'texlive-science')
source=('git+https://github.com/sdaps/sdaps.git'
'git+https://github.com/sdaps/sdaps-class.git')
md5sums=('SKIP'
@@ -27,22 +35,24 @@ pkgver() {
prepare() {
cd "$srcdir/sdaps"
- git submodule init
- git config submodule.sdaps-class.url $srcdir/sdaps-class
- git submodule update
+ git submodule init
+ git config submodule.sdaps-class.url $srcdir/sdaps-class
+ git submodule update
}
build() {
- cd "$srcdir/sdaps"
- python2 setup.py build
+ cd "$srcdir/sdaps"
+ python setup.py build
}
check() {
- cd "$srcdir/sdaps/test"
- ./run-test-locally.sh
+ cd "$srcdir/sdaps/test"
+ ./run-test-locally.sh
}
package() {
cd "$srcdir/sdaps"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ python setup.py install --root="$pkgdir/" --optimize=1
+ mkdir -p $pkgdir/usr/share/texmf/tex/latex/sdaps
+ cp $pkgdir/usr/share/sdaps/tex/* $pkgdir/usr/share/texmf/tex/latex/sdaps
}