summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgit user2024-11-07 14:26:04 +0100
committergit user2024-11-07 14:26:04 +0100
commit1e8010278c5f88bd063515dfd685f1da9d34e718 (patch)
treeca84710ee3aac6d866a39de7b9548e0165421eed
parent2557f3962a4265aa3b5f741398167c216ab6bfa9 (diff)
downloadaur-1e8010278c5f88bd063515dfd685f1da9d34e718.tar.gz
Updated `pkgver()` to use `+` symbol as separator between last release version and number of additional commits.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7198fb4c1729..5060e6226fb3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sdbus-cpp-nosystemd-git
pkgdesc = sdbus-c++ is a high-level C++ D-Bus library for Linux designed to provide expressive, easy-to-use API in modern C++. This package is without systemd dependencies; it will have it's own static libsystemd baked in.
pkgver = 2.0.0.11.r442.d20241031.84130b1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Kistler-Group/sdbus-cpp
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b1228904cd37..3513b2957572 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _pkgvariant=nosystemd
pkgname="${_pkgname}-${_pkgvariant}-git"
_pkgver=latest
pkgver=2.0.0.11.r442.d20241031.84130b1
-pkgrel=1
+pkgrel=2
pkgdesc="sdbus-c++ is a high-level C++ D-Bus library for Linux designed to provide expressive, easy-to-use API in modern C++. This package is without systemd dependencies; it will have it's own static libsystemd baked in."
url="https://github.com/Kistler-Group/sdbus-cpp"
arch=('i686' 'x86_64')
@@ -59,7 +59,7 @@ pkgver() {
error "Error in ${FUNCNAME[0]}: Version information could not determined."
return 1
fi
- printf '%s' "${_ver}.${_subver}.r${_rev}.d${_date}.${_hash}"
+ printf '%s' "${_ver}+${_subver}.r${_rev}.d${_date}.${_hash}"
}
prepare() {