summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2019-02-24 11:47:30 -0500
committerTed Alff2019-02-24 11:47:30 -0500
commit8cfbaff0112e25abc65ffe7a7bb7f1aebae6b49e (patch)
tree168860af39e09cfec65490c3efeef8549902a2dd
downloadaur-8cfbaff0112e25abc65ffe7a7bb7f1aebae6b49e.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d8a574cbe07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = sdbusplus
+ pkgdesc = C++ bindings for systemd dbus APIs
+ pkgver = r298.3a3bb9e
+ pkgrel = 1
+ url = https://github.com/openbmc/sdbusplus
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ depends = systemd-libs
+ depends = python-mako
+ depends = python-inflection
+ depends = python-yaml
+ source = sdbusplus::git+https://github.com/openbmc/sdbusplus.git#commit=3a3bb9e932b2306dafd33ddd2eb31d61ff89b3fb
+ sha256sums = SKIP
+
+pkgname = sdbusplus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..855f54bb0e63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+pkgname=sdbusplus
+pkgver=r298.3a3bb9e
+pkgrel=1
+pkgdesc="C++ bindings for systemd dbus APIs"
+url="https://github.com/openbmc/sdbusplus"
+arch=('i686' 'x86_64')
+license=('Apache')
+depends=('systemd-libs' 'python-mako' 'python-inflection' 'python-yaml')
+makedepends=('git')
+_commit='3a3bb9e932b2306dafd33ddd2eb31d61ff89b3fb'
+source=("${pkgname}::git+https://github.com/openbmc/sdbusplus.git#commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+# git describe --long --tags | sed 's/^v//;s/-/+/g'
+}
+
+prepare() {
+ cd "${pkgname}"
+ ./bootstrap.sh
+ ./configure --prefix=/usr \
+ --enable-tests=no \
+ --disable-dependency-tracking #fails otherwise
+ # Avoid compile failure
+ sed -i '/@CODE_COVERAGE_RULES@/d' test/Makefile
+}
+
+build() {
+ cd "${pkgname}"
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="$pkgdir" install
+}