summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2019-03-30 16:29:37 -0400
committerTed Alff2019-03-30 16:29:37 -0400
commitd3b2b3e8627872034507565155f39fe44cb629c2 (patch)
tree023227744c116fe2f32cd2fadd5bcfe69de34ce7
parent8cfbaff0112e25abc65ffe7a7bb7f1aebae6b49e (diff)
downloadaur-d3b2b3e8627872034507565155f39fe44cb629c2.tar.gz
Move to new commit. Fixes compile errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d8a574cbe07..e5fcb059da78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sdbusplus
pkgdesc = C++ bindings for systemd dbus APIs
- pkgver = r298.3a3bb9e
+ pkgver = r305.8cd7a4a
pkgrel = 1
url = https://github.com/openbmc/sdbusplus
arch = i686
@@ -11,7 +11,7 @@ pkgbase = sdbusplus
depends = python-mako
depends = python-inflection
depends = python-yaml
- source = sdbusplus::git+https://github.com/openbmc/sdbusplus.git#commit=3a3bb9e932b2306dafd33ddd2eb31d61ff89b3fb
+ source = sdbusplus::git+https://github.com/openbmc/sdbusplus.git#commit=
sha256sums = SKIP
pkgname = sdbusplus
diff --git a/PKGBUILD b/PKGBUILD
index 855f54bb0e63..f75a56363375 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: twa022 <twa022 at gmail dot com>
pkgname=sdbusplus
-pkgver=r298.3a3bb9e
+pkgver=r305.8cd7a4a
pkgrel=1
pkgdesc="C++ bindings for systemd dbus APIs"
url="https://github.com/openbmc/sdbusplus"
@@ -9,24 +9,20 @@ arch=('i686' 'x86_64')
license=('Apache')
depends=('systemd-libs' 'python-mako' 'python-inflection' 'python-yaml')
makedepends=('git')
-_commit='3a3bb9e932b2306dafd33ddd2eb31d61ff89b3fb'
+#_commit='8cd7a4a10c02a450bc21580a4bde34328a841d13'
source=("${pkgname}::git+https://github.com/openbmc/sdbusplus.git#commit=${_commit}")
sha256sums=('SKIP')
pkgver() {
cd "${pkgname}"
echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
-# git describe --long --tags | sed 's/^v//;s/-/+/g'
}
prepare() {
cd "${pkgname}"
./bootstrap.sh
./configure --prefix=/usr \
- --enable-tests=no \
- --disable-dependency-tracking #fails otherwise
- # Avoid compile failure
- sed -i '/@CODE_COVERAGE_RULES@/d' test/Makefile
+ --enable-tests=no
}
build() {