summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernando Manfredi2015-06-08 09:58:45 -0300
committerFernando Manfredi2015-06-08 09:58:45 -0300
commit61c2122c44c4c20871a53bbee92f04bb2986554d (patch)
treef3265ed11fc6e8e988cf8780ce0c97dcb9827a08
downloadaur-61c2122c44c4c20871a53bbee92f04bb2986554d.tar.gz
Initial import to AUR4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--sddm-acidhub-theme.install30
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb97c015ecc5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = sddm-acidhub-theme
+ pkgdesc = A hazardous style SDDM theme.
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://www.craft.net.br/
+ install = sddm-acidhub-theme.install
+ arch = any
+ license = GPL3
+ depends = sddm
+ source = http://web.craft.net.br/downloads/acidhub-0.2.tar.gz
+ source = sddm-acidhub-theme.install
+ sha512sums = c4bd4689efacaa17e7c7a67418420e123e963f909f20846b4f0b0f20a4810efd38a36595568f33c4dd49b0d8ddf44d65ac3d64b1c43242259d8139a40f1a1f00
+ sha512sums = fc57feb3cc1ecc7caf187efb0521dea9854f7c4bdeb15c3d960334ea9bf13f1230e1a39a5dccb56fa0f08b840f13607b9d366f7f5b2cb3f96cee921bb7877b8d
+
+pkgname = sddm-acidhub-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d501839b898
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: AcidHub <acidhub@craft.net.br>
+
+_themename=acidhub
+pkgname=sddm-${_themename}-theme
+pkgver=0.2
+pkgrel=1
+pkgdesc='A hazardous style SDDM theme.'
+arch=('any')
+url='https://www.craft.net.br/'
+license=('GPL3')
+
+depends=('sddm')
+
+install=${pkgname}.install
+
+source=(
+ "http://web.craft.net.br/downloads/${_themename}-${pkgver}.tar.gz"
+ "${pkgname}.install"
+)
+sha512sums=('c4bd4689efacaa17e7c7a67418420e123e963f909f20846b4f0b0f20a4810efd38a36595568f33c4dd49b0d8ddf44d65ac3d64b1c43242259d8139a40f1a1f00'
+ 'fc57feb3cc1ecc7caf187efb0521dea9854f7c4bdeb15c3d960334ea9bf13f1230e1a39a5dccb56fa0f08b840f13607b9d366f7f5b2cb3f96cee921bb7877b8d')
+
+package() {
+ cd ${srcdir}
+ msg2 "Installing theme..."
+ mkdir -p ${pkgdir}/usr/share/sddm/themes
+ cp -R ${_themename} ${pkgdir}/usr/share/sddm/themes
+}
diff --git a/sddm-acidhub-theme.install b/sddm-acidhub-theme.install
new file mode 100644
index 000000000000..8f2981433518
--- /dev/null
+++ b/sddm-acidhub-theme.install
@@ -0,0 +1,30 @@
+if test ! -z $(cat /etc/pacman.conf | grep '^Color'); then
+ color_reset="\e[0m"
+ bold_green="${color_reset}\e[1;32m"
+ bold_blue="${color_reset}\e[1;34m"
+ bold_white="${color_reset}\e[1;37m"
+ bold_underline_white="${color_reset}\e[4;1;37m"
+ bold_yellow="${color_reset}\e[1;33m"
+fi
+
+post_install() {
+ echo -e "${bold_green}==>${color_reset} ${bold_white}Edit your sddm.conf${color_reset}"
+ echo -e " ${bold_blue}->${color_reset} ${bold_white}Add ${bold_underline_white}acidhub${bold_white} as your current theme. Example:${color_reset}"
+ echo -e "\n[Theme]"
+ echo -e "# Current theme name"
+ echo -e "Current=${bold_underline_white}acidhub${color_reset}\n"
+ echo -e " ${bold_blue}->${color_reset} ${bold_white}More info at https://wiki.archlinux.org/index.php/SDDM${color_reset}"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ echo -e "${bold_yellow}==>${color_reset} ${bold_white}Edit your sddm.conf${color_reset}"
+ echo -e " ${bold_blue}->${color_reset} ${bold_white}Remove ${bold_underline_white}acidhub${bold_white} as your current theme. By default:${color_reset}"
+ echo -e "\n[Theme]"
+ echo -e "# Current theme name"
+ echo -e "Current=${bold_underline_white}maui${color_reset}\n"
+ echo -e " ${bold_blue}->${color_reset} ${bold_white}More info at https://wiki.archlinux.org/index.php/SDDM${color_reset}"
+}