summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2014-09-18 11:27:42 -0500
committerDoug Newgard2014-09-18 11:27:42 -0500
commitf56248960edea27ae50a9d3fbc9faa766eb86871 (patch)
treed691aeebb1498ef9c4ded31bac2755b905ed2780
downloadaur-f56248960edea27ae50a9d3fbc9faa766eb86871.tar.gz
Inherited from bchretein
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
-rw-r--r--sddm-archlinux-theme.install6
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c913bb2f0452
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = sddm-archlinux-theme-git
+ pkgdesc = Archlinux Theme for SDDM
+ pkgver = r11.8898d77
+ pkgrel = 2
+ url = https://github.com/absturztaube/sddm-archlinux-theme
+ install = sddm-archlinux-theme.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = sddm>=0.9.0
+ source = sddm-archlinux-theme-git::git+https://github.com/absturztaube/sddm-archlinux-theme.git
+ md5sums = SKIP
+
+pkgname = sddm-archlinux-theme-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..71a9d16c2b38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*~
+*/
+*.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75638981cf98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+_pkgname=sddm-archlinux-theme
+pkgname=$_pkgname-git
+pkgver=r11.8898d77
+pkgrel=2
+pkgdesc="Archlinux Theme for SDDM"
+license=('GPL')
+arch=('i686' 'x86_64')
+url="https://github.com/absturztaube/sddm-archlinux-theme"
+makedepends=('git')
+depends=('sddm>=0.9.0')
+source=("${pkgname}"::"git+https://github.com/absturztaube/sddm-archlinux-theme.git")
+md5sums=('SKIP')
+install="${_pkgname}.install"
+
+build() {
+ cd ${srcdir}/${pkgname}/archlinux
+ # Nothing to do
+}
+
+pkgver() {
+ cd ${pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${srcdir}/${pkgname}/archlinux
+
+ install -m 644 -D Main.qml ${pkgdir}/usr/share/sddm/themes/archlinux/Main.qml
+ install -m 644 -D angle-down.png ${pkgdir}/usr/share/sddm/themes/archlinux/angle-down.png
+ install -m 644 -D archlinux.qmlproject ${pkgdir}/usr/share/sddm/themes/archlinux/archlinux.qmlproject
+ install -m 644 -D archlinux.qmlproject.user ${pkgdir}/usr/share/sddm/themes/archlinux/archlinux.qmlproject.user
+ install -m 644 -D background.jpg ${pkgdir}/usr/share/sddm/themes/archlinux/background.jpg
+
+ install -m 644 -D theme.conf ${pkgdir}/usr/share/sddm/themes/archlinux/theme.conf
+ install -m 644 -D screenshot.png ${pkgdir}/usr/share/sddm/themes/archlinux/screenshot.png
+ install -m 644 -D metadata.desktop ${pkgdir}/usr/share/sddm/themes/archlinux/metadata.desktop
+}
diff --git a/sddm-archlinux-theme.install b/sddm-archlinux-theme.install
new file mode 100644
index 000000000000..f4899caf6c63
--- /dev/null
+++ b/sddm-archlinux-theme.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo "To use this theme, add the following lines to /etc/sddm.conf:"
+ echo
+ echo "[Theme]"
+ echo "Current=archlinux"
+}