summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2015-11-04 21:20:02 +0000
committerAntonio Rojas2015-11-04 21:20:02 +0000
commit53489289a1d78fb971acd932b05c02ce735c34f1 (patch)
tree7ec1afc4aeaf46774a1773e6e1c4c70af9c7ff74
parent0baf5ec430349c01ee4ee45c2cda911ae083fdee (diff)
downloadaur-53489289a1d78fb971acd932b05c02ce735c34f1.tar.gz
Update to 0.13.0
-rw-r--r--PKGBUILD22
1 files changed, 4 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b084755a115e..2f243905f2b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=sddm
-pkgver=0.12.0
-pkgrel=5
+pkgver=0.13.0
+pkgrel=1
pkgdesc='QML based X11 display manager'
arch=('i686' 'x86_64')
url='http://github.com/sddm/sddm'
@@ -14,25 +14,11 @@ install="${pkgname}.install"
backup=('usr/share/sddm/scripts/Xsetup'
'etc/pam.d/sddm')
provides=('display-manager')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz"
- fix-segfault.patch::"https://github.com/davispuh/sddm/commit/671c11d0.patch"
- CVE-2015-0856.patch::"https://github.com/sddm/sddm/commit/4cfed6b0.patch"
- multi-monitor.patch::"https://patch-diff.githubusercontent.com/raw/sddm/sddm/pull/511.patch")
-md5sums=('e3261ac93a50c71c973cc79b85387765'
- '208f3b1b49792984989172dd809a03bf'
- '80eb7eddd8d3d259a6c28e83b9394575'
- '1704e84c68e6935923d223b6a4c4b198')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('ecfd285a463eb6490da1333bb2e304a7')
prepare() {
mkdir -p build
-
-# Fix segfault https://github.com/sddm/sddm/issues/489
- cd $pkgname-$pkgver
- patch -p1 -i ../fix-segfault.patch
-# Fix CVE-2015-0856
- patch -p1 -i ../CVE-2015-0856.patch
-# Fix multi-monitor support https://github.com/sddm/sddm/issues/496
- patch -p1 -i ../multi-monitor.patch
}
build() {