summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Osler2017-09-02 15:10:44 -0700
committerWilliam Osler2017-09-02 15:27:45 -0700
commitcfa6440b2818eacebea019b04fe7ece0a97a8bed (patch)
tree6f52a224e7a690edc0b0dd1ee54f1aa64a9c3648
parent2da9469f07e9a1c74bc6b30085a89fbbffc81440 (diff)
downloadaur-cfa6440b2818eacebea019b04fe7ece0a97a8bed.tar.gz
add custom tweaks
-rw-r--r--.SRCINFO19
-rw-r--r--24-hour-date.patch11
-rw-r--r--PKGBUILD26
-rw-r--r--sddm-old-breeze-theme-tweak.install (renamed from sddm-old-breeze-theme.install)0
-rw-r--r--smooth-user-pic.patch19
5 files changed, 62 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b44cbf76f587..e87c0642a41a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,23 @@
-pkgbase = sddm-old-breeze-theme
- pkgdesc = Plasma 5.7 Breeze SDDM Theme
- pkgver = 1.0
+pkgbase = sddm-old-breeze-theme-tweak
+ pkgdesc = Plasma 5.7 Breeze SDDM Theme, with 24 hour time and smoother user images
+ pkgver = 5.7
pkgrel = 1
url = https://github.com/sddm/sddm
- install = sddm-old-breeze-theme.install
+ install = sddm-old-breeze-theme-tweak.install
arch = any
license = CC-BY-SA
depends = sddm
+ depends = plasma-workspace
+ provides = sddm-old-breeze-theme
+ conflicts = sddm-old-breeze-theme
source = https://github.com/gregodadone/sddm-old-breeze-theme/raw/master/breeze-5.7.tar.gz
- source = sddm-old-breeze-theme.install
+ source = sddm-old-breeze-theme-tweak.install
+ source = 24-hour-date.patch
+ source = smooth-user-pic.patch
md5sums = 4be8292c5b47e8b59105334127afa4a8
md5sums = be5b8bb99f930776c91d580cd36f9cfe
+ md5sums = 572ad902e6c3b5f32cb4dfb36f17b094
+ md5sums = bf79c1ddd0eacc1fac7c73c87927edd3
-pkgname = sddm-old-breeze-theme
+pkgname = sddm-old-breeze-theme-tweak
diff --git a/24-hour-date.patch b/24-hour-date.patch
new file mode 100644
index 000000000000..c15782eafd3d
--- /dev/null
+++ b/24-hour-date.patch
@@ -0,0 +1,11 @@
+--- a/src/breeze-5.7/components/InfoPane.qml 2016-09-13 04:16:35.000000000 -0700
++++ b/src/breeze-5.7/components/InfoPane.qml 2017-07-15 15:20:05.183460860 -0700
+@@ -27,7 +27,7 @@
+
+ ColumnLayout {
+ BreezeLabel { //should be a heading but we want it _loads_ bigger
+- text: Qt.formatTime(timeSource.data["Local"]["DateTime"])
++ text: Qt.formatTime(timeSource.data["Local"]["DateTime"], "hh:mm:ss")
+ //we fill the width then align the text so that we can make the text shrink to fit
+ Layout.fillWidth: true
+ horizontalAlignment: Text.AlignRight
diff --git a/PKGBUILD b/PKGBUILD
index 20a636fd6eda..8557150c0a2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,32 @@
-# Maintainer: Grego Dadone <grego.dadone at gmail dot com>
+# Maintainer: William Osler <william at oslers dot us>
+# Contributor: Grego Dadone <grego.dadone at gmail dot com>
-pkgname=sddm-old-breeze-theme
-pkgver=1.0
+pkgname=sddm-old-breeze-theme-tweak
+pkgver=5.7
pkgrel=1
-pkgdesc="Plasma 5.7 Breeze SDDM Theme"
+pkgdesc="Plasma 5.7 Breeze SDDM Theme, with 24 hour time and smoother user images"
arch=('any')
url="https://github.com/sddm/sddm"
license=('CC-BY-SA')
-depends=('sddm')
+depends=('sddm' 'plasma-workspace')
+conflicts=('sddm-old-breeze-theme')
+provides=('sddm-old-breeze-theme')
install="$pkgname.install"
source=("https://github.com/gregodadone/sddm-old-breeze-theme/raw/master/breeze-5.7.tar.gz"
- "${pkgname}.install")
+ "${pkgname}.install"
+ "24-hour-date.patch"
+ "smooth-user-pic.patch")
md5sums=('4be8292c5b47e8b59105334127afa4a8'
- 'be5b8bb99f930776c91d580cd36f9cfe')
+ 'be5b8bb99f930776c91d580cd36f9cfe'
+ '572ad902e6c3b5f32cb4dfb36f17b094'
+ 'bf79c1ddd0eacc1fac7c73c87927edd3')
package() {
mkdir -p "${pkgdir}"/usr/share/sddm/themes
cp -R breeze-5.7 "${pkgdir}"/usr/share/sddm/themes/breeze-5.7
}
+
+prepare() {
+ patch -p2 -i 24-hour-date.patch
+ patch -p2 -i smooth-user-pic.patch
+}
diff --git a/sddm-old-breeze-theme.install b/sddm-old-breeze-theme-tweak.install
index 74cfe2a32787..74cfe2a32787 100644
--- a/sddm-old-breeze-theme.install
+++ b/sddm-old-breeze-theme-tweak.install
diff --git a/smooth-user-pic.patch b/smooth-user-pic.patch
new file mode 100644
index 000000000000..57232d19d109
--- /dev/null
+++ b/smooth-user-pic.patch
@@ -0,0 +1,19 @@
+--- a/src/breeze-5.7/components/UserDelegate.qml 2016-09-13 04:16:35.000000000 -0700
++++ b/src/breeze-5.7/components/UserDelegate.qml 2017-07-15 17:17:43.043366299 -0700
+@@ -18,7 +18,7 @@
+ * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+ */
+
+-import QtQuick 2.2
++import QtQuick 2.3
+
+ import org.kde.plasma.core 2.0 as PlasmaCore
+ import org.kde.plasma.components 2.0 as PlasmaComponents
+@@ -81,6 +81,7 @@
+ //we try loading it as a normal image, if that fails we fall back to IconItem
+ Image {
+ id: face
++ mipmap: true
+ source: wrapper.iconSource
+ anchors {
+ fill: frame