summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmil Lundberg2017-03-05 01:21:51 +0100
committerEmil Lundberg2017-03-05 01:21:51 +0100
commit8d237686999c6875b70e592bdd99acab52cff006 (patch)
treee304b0c3365c3ab9d51f6410227df2577ffd1fbe
downloadaur-8d237686999c6875b70e592bdd99acab52cff006.tar.gz
Initial commit
there will be many others but this one is first
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD25
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d64f5e0053e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sddm-theme-abstractdark-git
+ pkgdesc = Abstract Dark theme for SDDM by 3ximus
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/3ximus/abstractdark-sddm-theme
+ arch = any
+ license = CCPL:cc-by-sa
+ depends = sddm
+ source = git+https://github.com/3ximus/abstractdark-sddm-theme.git
+ md5sums = SKIP
+
+pkgname = sddm-theme-abstractdark-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..082a3865a458
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+/pkg/
+/src/
+/*.src.tar.gz
+/*.src.tar.gz.sig
+/*.tar.xz
+/*.tar.xz.sig
+
+/abstractdark-sddm-theme/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dc6a4f6dada
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Emil Lundberg <emil@emlun.se>
+
+pkgname=sddm-theme-abstractdark-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Abstract Dark theme for SDDM by 3ximus"
+arch=('any')
+url="https://github.com/3ximus/abstractdark-sddm-theme"
+license=('CCPL:cc-by-sa')
+depends=('sddm')
+_theme_name='abstractdark'
+_repo_name='abstractdark-sddm-theme'
+source=("git+https://github.com/3ximus/abstractdark-sddm-theme.git")
+md5sums=('SKIP')
+
+pkgver() {
+ echo "$(git -C "${srcdir}/${_repo_name}" rev-list --count HEAD).0.0"
+}
+
+package() {
+ install -d "${pkgdir}"/usr/share/sddm/themes/"${_theme_name}"
+ cp -r "${srcdir}/${_repo_name}"/* "${pkgdir}"/usr/share/sddm/themes/"${_theme_name}"/
+ find "${pkgdir}"/usr/share/sddm/themes/"${_theme_name}" -type d -exec chmod 555 {} \;
+ find "${pkgdir}"/usr/share/sddm/themes/"${_theme_name}" -type f -exec chmod 444 {} \;
+}