summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGenerator2017-07-17 20:54:19 +0100
committerGenerator2017-07-17 20:54:19 +0100
commit89d9d9ea752bea5e30a79e95aa1f819d04bae556 (patch)
tree2829e66983d4c9ad9818afeb3bdc1a887e5a2ea7
downloadaur-89d9d9ea752bea5e30a79e95aa1f819d04bae556.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
-rw-r--r--sddm-theme-aerial.install10
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..375bdcc996ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Jul 17 19:54:04 UTC 2017
+pkgbase = sddm-theme-aerial-git
+ pkgdesc = SDDM theme with Apple TV Aerial videos
+ pkgver = 0.1.r16.gca72b8d
+ pkgrel = 1
+ url = https://github.com/3ximus/aerial-sddm-theme
+ install = sddm-theme-aerial.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = sddm
+ source = git+https://github.com/3ximus/aerial-sddm-theme.git
+ sha256sums = SKIP
+
+pkgname = sddm-theme-aerial-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e7176d2b274
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: American_Jesus <american.jesus.pt AT gmail DOT com>
+
+_repo=aerial-sddm-theme
+_pkgname=sddm-theme-aerial
+pkgname=$_pkgname-git
+pkgver=0.1.r16.gca72b8d
+pkgrel=1
+pkgdesc="SDDM theme with Apple TV Aerial videos"
+arch=('any')
+url="https://github.com/3ximus/aerial-sddm-theme"
+license=('GPL')
+depends=('sddm')
+makedepends=('git')
+install="$_pkgname.install"
+source=("git+https://github.com/3ximus/$_repo.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_repo
+
+ local _ver=$(awk -F '=' '/Version/ {print $2}' metadata.desktop)
+ printf '%s.r%s.g%s' "$_ver" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+build() {
+ cd $_repo
+ rm preview*.gif
+}
+package() {
+ install -Dm644 -t "$pkgdir/usr/share/sddm/themes/aerial/" $_repo/*
+}
diff --git a/sddm-theme-aerial.install b/sddm-theme-aerial.install
new file mode 100644
index 000000000000..7a6f0eedd732
--- /dev/null
+++ b/sddm-theme-aerial.install
@@ -0,0 +1,10 @@
+post_install() {
+ cat << _EOF
+
+==> Installation:
+==> To use this theme, add the following lines to /etc/sddm.conf:"
+==>
+==> [Theme]"
+==> Current=archlinux"
+_EOF
+}