summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmil Lundberg2017-03-05 01:30:39 +0100
committerEmil Lundberg2017-03-05 01:30:39 +0100
commit22e4b976140172d0650de2fe49fdbf4f45148ff2 (patch)
tree81a0d5dd522e9c7a63c4bce2bc72c39ddfb2f47d
downloadaur-22e4b976140172d0650de2fe49fdbf4f45148ff2.tar.gz
Initial commit
there will be many others but this one is first
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD25
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df818dd5e22a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = sddm-theme-deepin-git
+ pkgdesc = Deepin Theme for SDDM by Match-Yang
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/Match-Yang/sddm-deepin
+ arch = any
+ license = CCPL:cc-by-sa
+ depends = sddm
+ depends = qt5-graphicaleffects
+ source = git+https://github.com/Match-Yang/sddm-deepin.git#branch=master
+ md5sums = SKIP
+
+pkgname = sddm-theme-deepin-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9c402efb6949
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+/pkg/
+/src/
+/*.src.tar.gz
+/*.src.tar.gz.sig
+/*.tar.xz
+/*.tar.xz.sig
+
+/sddm-deepin/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d38a6d685f9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Emil Lundberg <emil@emlun.se>
+
+pkgname=sddm-theme-deepin-git
+pkgver=latest
+pkgrel=1
+pkgdesc="Deepin Theme for SDDM by Match-Yang"
+arch=('any')
+url="https://github.com/Match-Yang/sddm-deepin"
+license=('CCPL:cc-by-sa')
+depends=('sddm' 'qt5-graphicaleffects')
+_theme_name='deepin'
+_repo_name='sddm-deepin'
+source=("git+https://github.com/Match-Yang/${_repo_name}.git#branch=master")
+md5sums=('SKIP')
+
+pkgver() {
+ echo "$(git -C "${srcdir}/${_repo_name}" rev-list --count HEAD).0.0"
+}
+
+package() {
+ install -d "${pkgdir}"/usr/share/sddm/themes/"${_theme_name}"
+ cp -r "${srcdir}/${_repo_name}/${_theme_name}"/* "${pkgdir}"/usr/share/sddm/themes/"${_theme_name}"/
+ find "${pkgdir}"/usr/share/sddm/themes/"${_theme_name}" -type d -exec chmod 555 {} \;
+ find "${pkgdir}"/usr/share/sddm/themes/"${_theme_name}" -type f -exec chmod 444 {} \;
+}