summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur2023-05-19 15:48:41 +0200
committerArthur2023-05-19 15:48:41 +0200
commitb76bd9d8e2bb1a1d2fce205ddce00aebe246e654 (patch)
treed424a771ff5a2f3605cb1bd092328c578b0b33dd
downloadaur-b76bd9d8e2bb1a1d2fce205ddce00aebe246e654.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e96d584dee18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = sddm-theme-mountain-git
+ pkgdesc = Mountain theme for SDDM.
+ pkgver = 1.1.0.r0.gd6d9b20
+ pkgrel = 1
+ url = https://github.com/c0rydoras/sddm-mountain-theme.git
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = sddm
+ depends = qt5-graphicaleffects
+ depends = qt5-quickcontrols2
+ depends = qt5-svg
+ depends = ttf-droid
+ provides = sddm-theme-mountain
+ conflicts = sddm-theme-mountain
+ backup = usr/share/sddm/themes/mountain/theme.conf
+ source = mountain::git+https://github.com/c0rydoras/sddm-mountain-theme.git
+ sha256sums = SKIP
+
+pkgname = sddm-theme-mountain-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bf61a6c0892
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Arthur Deierlein <arthur.deierlein@adfinis.com>
+
+pkgname=sddm-theme-mountain-git
+pkgdesc="Mountain theme for SDDM."
+pkgver=1.1.0.r0.gd6d9b20
+pkgrel=1
+arch=('any')
+url="https://github.com/c0rydoras/sddm-mountain-theme.git"
+license=('GPL3')
+depends=('sddm' 'qt5-graphicaleffects' 'qt5-quickcontrols2' 'qt5-svg' 'ttf-droid')
+makedepends=('git')
+provides=("sddm-theme-mountain")
+conflicts=("sddm-theme-mountain")
+backup=('usr/share/sddm/themes/mountain/theme.conf')
+source=('mountain::git+https://github.com/c0rydoras/sddm-mountain-theme.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/mountain"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+
+package() {
+ cd "$srcdir/mountain"
+ install -Dm644 "Main.qml" "$pkgdir/usr/share/sddm/themes/mountain/Main.qml"
+ install -Dm644 "theme.conf" "$pkgdir/usr/share/sddm/themes/mountain/theme.conf"
+ install -Dm644 "metadata.desktop" "$pkgdir/usr/share/sddm/themes/mountain/metadata.desktop"
+ find ./Assets -type f -exec install -Dm644 {} "$pkgdir/usr/share/sddm/themes/mountain/{}" \;
+ find ./Backgrounds -type f -exec install -Dm644 {} "$pkgdir/usr/share/sddm/themes/mountain/{}" \;
+ find ./Components -type f -exec install -Dm644 {} "$pkgdir/usr/share/sddm/themes/mountain/{}" \;
+ install -Dm 644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
+