summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Maurer2016-07-03 03:25:36 +0200
committerFabian Maurer2016-07-03 03:25:36 +0200
commit0765b04ac4e04b2bb2af6de158d0b8d39a2c0f55 (patch)
tree697af39942144f64301fb56f2b1328ab19dcdb22
downloadaur-0765b04ac4e04b2bb2af6de158d0b8d39a2c0f55.tar.gz
Initial commit for sdfs.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
-rw-r--r--mkfs.patch6
-rw-r--r--mount.patch15
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd448195e882
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = sdfs
+ pkgdesc = Deduplication file system from Opendedup
+ pkgver = 3.1.7
+ pkgrel = 1
+ url = http://opendedup.org
+ arch = x86_64
+ license = GPL2
+ depends = libxml2
+ depends = java-environment
+ depends = fuse
+ source = https://github.com/opendedup/sdfs/archive/3.1.7.zip
+ source = mount.patch
+ source = mkfs.patch
+ md5sums = cdc1af3868c8a2660e16796fcee6f636
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = sdfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6b3095d4c9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Fabian Maurer <dark.shadow4@web.de>
+
+pkgname=sdfs
+pkgver=3.1.7
+pkgrel=1
+pkgdesc="Deduplication file system from Opendedup"
+arch=('x86_64')
+url="http://opendedup.org"
+license=('GPL2')
+depends=('libxml2' 'java-environment' 'fuse')
+source=('https://github.com/opendedup/sdfs/archive/3.1.7.zip'
+ 'mount.patch'
+ 'mkfs.patch')
+md5sums=('cdc1af3868c8a2660e16796fcee6f636'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd ${srcdir}/$pkgname-$pkgver/install-packages/deb
+ patch usr/share/sdfs/mount.sdfs < ${srcdir}/mount.patch
+ patch usr/share/sdfs/mkfs.sdfs < ${srcdir}/mkfs.patch
+}
+
+package() {
+ cd ${srcdir}/$pkgname-$pkgver/install-packages/deb
+
+ cp -dr --no-preserve=ownership etc ${pkgdir}
+ cp -dr --no-preserve=ownership usr ${pkgdir}
+
+ install -d ${pkgdir}/usr/bin/
+ install -D sbin/* ${pkgdir}/usr/bin
+}
diff --git a/mkfs.patch b/mkfs.patch
new file mode 100644
index 000000000000..fa4054d026d9
--- /dev/null
+++ b/mkfs.patch
@@ -0,0 +1,6 @@
+--- mkfs.sdfs 2016-07-03 00:48:24.582190077 +0200
++++ mod-mkfs.sdfs 2016-06-06 21:54:29.000000000 +0200
+@@ -1,2 +1,2 @@
+-/usr/share/sdfs/bin/jre/bin/java -Dfile.encoding=UTF-8 -classpath /usr/share/sdfs/lib/sdfs.jar:/usr/share/sdfs/lib/* org.opendedup.sdfs.VolumeConfigWriter "$@"
++java -Dfile.encoding=UTF-8 -classpath /usr/share/sdfs/lib/sdfs.jar:/usr/share/sdfs/lib/* org.opendedup.sdfs.VolumeConfigWriter "$@"
+
diff --git a/mount.patch b/mount.patch
new file mode 100644
index 000000000000..a4f3e2b860aa
--- /dev/null
+++ b/mount.patch
@@ -0,0 +1,15 @@
+--- mount.sdfs 2016-04-17 20:43:31.000000000 +0200
++++ mod-mount.sdfs 2016-07-03 00:46:23.919483868 +0200
+@@ -36,11 +36,8 @@
+ else
+ MEMORY=$MEM
+ fi
+-else
+- MEMORY=$MEM
+-fi
+
+-LD_PRELOAD="/usr/share/sdfs/bin/libfuse.so.2" $EXEC -server -outfile '&1' -errfile '&2' -Djava.library.path=/usr/share/sdfs/bin/ -home /usr/share/sdfs/bin/jre -Dorg.apache.commons.logging.Log=fuse.logging.FuseLog\
++LD_PRELOAD="/usr/share/sdfs/bin/libfuse.so.2" $EXEC -server -outfile '&1' -errfile '&2' -Djava.library.path=/usr/share/sdfs/bin/ -home /usr/lib/jvm/default-runtime -Dorg.apache.commons.logging.Log=fuse.logging.FuseLog\
+ -Dfuse.logging.level=INFO -Xmx$MEMORY$MU -Xms$MEMORY$MU \
+ -XX:+DisableExplicitGC -pidfile /var/run/$PF -XX:+UseG1GC -Djava.awt.headless=true \
+ -cp /usr/share/sdfs/lib/commons-daemon-1.0.15.jar:/usr/share/sdfs/lib/sdfs.jar:/usr/share/sdfs/lib/* fuse.SDFS.MountSDFS "$@"