summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Maurer2018-04-28 18:19:33 +0200
committerFabian Maurer2018-04-28 18:19:33 +0200
commit8ce35eca120c73e339003b2acd866ae7187b61e5 (patch)
treec87e9c467a12e9ab541fb5608f259665e79299fa
parent669b5bb4f21b98598d8daf7da404c1f953dd3582 (diff)
downloadaur-8ce35eca120c73e339003b2acd866ae7187b61e5.tar.gz
Update to SDFS 3.6.0.10, now build from source
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD30
2 files changed, 28 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82d266199192..c4768eaa0806 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = sdfs
pkgdesc = Deduplication file system from Opendedup
- pkgver = 3.2.1
+ pkgver = 3.6.0.10
pkgrel = 1
url = http://opendedup.org
arch = x86_64
license = GPL2
+ makedepends = maven
depends = libxml2
depends = java-runtime
depends = fuse
- source = https://github.com/opendedup/sdfs/archive/3.2.1.zip
- md5sums = 33099d698ada4ade03a33df5dcf33d58
+ source = https://github.com/opendedup/sdfs/archive/3.6.0.10.zip
+ source = https://raw.githubusercontent.com/opendedup/sdfs/3.7/install-packages/deb/usr/share/sdfs/mount.sdfs
+ md5sums = 144ea71338a8250216dbe446b1940eec
+ md5sums = 591288969f6b79b4557b2ca8a1ac78f6
pkgname = sdfs
diff --git a/PKGBUILD b/PKGBUILD
index d276d74a6c4c..eab0e1abbf3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,42 @@
# Maintainer: Fabian Maurer <dark.shadow4@web.de>
pkgname=sdfs
-pkgver=3.2.1
+pkgver=3.6.0.10
pkgrel=1
pkgdesc="Deduplication file system from Opendedup"
arch=('x86_64')
url="http://opendedup.org"
license=('GPL2')
+makedepends=('maven')
depends=('libxml2' 'java-runtime' 'fuse')
-source=('https://github.com/opendedup/sdfs/archive/3.2.1.zip')
-md5sums=('33099d698ada4ade03a33df5dcf33d58')
+source=(https://github.com/opendedup/sdfs/archive/${pkgver}.zip
+ https://raw.githubusercontent.com/opendedup/sdfs/3.7/install-packages/deb/usr/share/sdfs/mount.sdfs)
+md5sums=('144ea71338a8250216dbe446b1940eec'
+ '591288969f6b79b4557b2ca8a1ac78f6')
-prepare() {
- cd "${srcdir}/$pkgname-$pkgver/install-packages/deb"
-
- ln -s /usr/lib/jvm/default-runtime usr/share/sdfs/bin/jre
+build () {
+ cd "${srcdir}/$pkgname-$pkgver"
+ JAVA_HOME=/usr/lib/jvm/default/jre mvn package
}
package() {
cd "${srcdir}/$pkgname-$pkgver/install-packages/deb"
+ if [ ! -d usr/share/sdfs/bin/jre ]; then
+ ln -s /usr/lib/jvm/default-runtime usr/share/sdfs/bin/jre
+ fi
+
cp -dr --no-preserve=ownership etc "${pkgdir}"
cp -dr --no-preserve=ownership usr "${pkgdir}"
-
+
install -d "${pkgdir}/usr/bin/"
cp -dr --no-preserve=ownership sbin/* "${pkgdir}/usr/bin"
+
+ cd "${srcdir}/$pkgname-$pkgver/target"
+ cp -dr --no-preserve=ownership lib/* "${pkgdir}/usr/share/sdfs/lib"
+ rm sdfs-*-with-dependencies.jar
+ cp --no-preserve=ownership sdfs-*.jar "${pkgdir}/usr/share/sdfs/lib/sdfs.jar"
+
+ #Take newer version of 'mount.sdfs' since current version is broken
+ cp "${srcdir}/mount.sdfs" "${pkgdir}/usr/share/sdfs/"
}