summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2020-09-27 11:32:35 +0200
committerMichael Straube2020-09-27 11:32:35 +0200
commitbc1634ec057216eb81d12e238f321ad3e40ec06f (patch)
tree23380ed82aad55f03936d6fce2f29f25cbd628ed
parentecb363f1fa832c886c2be9cdb116917a14bce5bd (diff)
downloadaur-sdl-ball.tar.gz
Update to 1.04
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82b0e2dd89ad..9ba834202ab3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sdl-ball
pkgdesc = A Breakout clone with pretty graphics
- pkgver = 1.03
- pkgrel = 3
+ pkgver = 1.04
+ pkgrel = 1
url = http://sdl-ball.sourceforge.net/
arch = x86_64
license = GPL3
@@ -10,8 +10,8 @@ pkgbase = sdl-ball
depends = sdl_ttf
depends = sdl_image
depends = wiiuse
- source = https://sourceforge.net/projects/sdl-ball/files/SDL-Ball_1.03_build-6_src.tar.xz
- sha256sums = 6910a7166d16e3bfe4a67b538d02e25eec0d06276aef399b9143fd246cd76442
+ source = https://github.com/DusteDdk/SDL-Ball/archive/1.04/sdl-ball-1.04.tar.gz
+ sha512sums = c2e45f3663dc79762bf88d23d19fa875fca6dc73cd38e5e80f803072b7761bb2f98a3b20a16ea14b7d260624602892914aa96b9a485ca16cb5dadcfacd3dd57c
pkgname = sdl-ball
diff --git a/PKGBUILD b/PKGBUILD
index 780648e1622f..2a55710c6e0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,28 @@
# Contributor: Christoph Zeiler <rabyte*gmail>
pkgname=sdl-ball
-pkgver=1.03
-pkgrel=3
+pkgver=1.04
+pkgrel=1
pkgdesc="A Breakout clone with pretty graphics"
arch=('x86_64')
url="http://sdl-ball.sourceforge.net/"
license=('GPL3')
depends=('glu' 'sdl_mixer' 'sdl_ttf' 'sdl_image' 'wiiuse')
-source=("https://sourceforge.net/projects/sdl-ball/files/SDL-Ball_${pkgver}_build-6_src.tar.xz")
-sha256sums=('6910a7166d16e3bfe4a67b538d02e25eec0d06276aef399b9143fd246cd76442')
+source=("https://github.com/DusteDdk/SDL-Ball/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('c2e45f3663dc79762bf88d23d19fa875fca6dc73cd38e5e80f803072b7761bb2f98a3b20a16ea14b7d260624602892914aa96b9a485ca16cb5dadcfacd3dd57c')
build() {
- cd SDL-Ball_source_build_0006_src
+ cd SDL-Ball-$pkgver
export LIBS='-lwiiuse'
export CPPFLAGS+=' -DWITH_WIIUSE'
- export CFLAGS="$CXXFLAGS $CPPFLAGS"
+ export CXXFLAGS+=" $CPPFLAGS"
make DATADIR="/usr/share/sdl-ball/themes/"
}
package() {
- cd SDL-Ball_source_build_0006_src
+ cd SDL-Ball-$pkgver
install -d "$pkgdir"/usr/share/sdl-ball/leveleditor
cp -r README themes "$pkgdir"/usr/share/sdl-ball/