summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2018-11-24 14:33:45 +0100
committerMichael Straube2018-11-24 14:33:45 +0100
commit2748292b1c7cac1cccef439baa4dcf95d176846b (patch)
treecb3333848b958675ba3846bc789867291d83d59f
parent2edc2604d207cb064d01a7369b084c8a1c720bdd (diff)
downloadaur-2748292b1c7cac1cccef439baa4dcf95d176846b.tar.gz
Add back the package
- build with Wiimote support - remove GIMP leveleditor
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD28
2 files changed, 8 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d98805cdca43..82b0e2dd89ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = sdl-ball
pkgdesc = A Breakout clone with pretty graphics
pkgver = 1.03
- pkgrel = 2
+ pkgrel = 3
url = http://sdl-ball.sourceforge.net/
- arch = i686
arch = x86_64
license = GPL3
depends = glu
depends = sdl_mixer
depends = sdl_ttf
depends = sdl_image
+ depends = wiiuse
source = https://sourceforge.net/projects/sdl-ball/files/SDL-Ball_1.03_build-6_src.tar.xz
sha256sums = 6910a7166d16e3bfe4a67b538d02e25eec0d06276aef399b9143fd246cd76442
diff --git a/PKGBUILD b/PKGBUILD
index e9f4bd96c459..c147e272add0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,27 @@
# Maintainer:
+# Contributor: Michael Straube <michael.straube@posteo.de>
# Contributor: yugrotavele <yugrotavele at archlinux dot us>
# Contributor: Christoph Zeiler <rabyte*gmail>
pkgname=sdl-ball
pkgver=1.03
-pkgrel=2
+pkgrel=3
pkgdesc="A Breakout clone with pretty graphics"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://sdl-ball.sourceforge.net/"
license=('GPL3')
-depends=('glu' 'sdl_mixer' 'sdl_ttf' 'sdl_image')
+depends=('glu' 'sdl_mixer' 'sdl_ttf' 'sdl_image' 'wiiuse')
source=("https://sourceforge.net/projects/sdl-ball/files/SDL-Ball_${pkgver}_build-6_src.tar.xz")
sha256sums=('6910a7166d16e3bfe4a67b538d02e25eec0d06276aef399b9143fd246cd76442')
-# uncomment if building with wiimote support
-#depends+=('wiiuse')
-
-# uncomment if building the gimp leveleditor
-#depends+=('gimp')
-
build() {
cd SDL-Ball_source_build_0006_src
- # uncomment to build with wiimote support
- #export LIBS='-lwiiuse'
- #export CPPFLAGS+=' -DWITH_WIIUSE'
+ export LIBS='-lwiiuse'
+ export CPPFLAGS+=' -DWITH_WIIUSE'
export CFLAGS="$CXXFLAGS $CPPFLAGS"
make DATADIR="/usr/share/sdl-ball/themes/"
-
- # uncomment to build the gimp leveleditor
- #cd leveleditor/gimp-leveleditor
- #gimptool-2.0 --build gimp-sdlball.c
}
package() {
@@ -43,10 +33,4 @@ package() {
install -Dm755 sdl-ball "$pkgdir"/usr/bin/sdl-ball
install -Dm644 themes/default/icon32.png "$pkgdir"/usr/share/pixmaps/sdl-ball.png
install -Dm644 sdl-ball.desktop "$pkgdir"/usr/share/applications/sdl-ball.desktop
-
- # uncomment to install the gimp leveleditor
- #cd leveleditor/gimp-leveleditor
- #install -Dm755 gimp-sdlball "$pkgdir"/usr/lib/gimp/2.0/plug-ins/gimp-sdlball
- #install -Dm644 readme "$pkgdir"/usr/share/sdl-ball/leveleditor/gimp-leveleditor/readme
- #install -Dm644 sdlball.xcf "$pkgdir"/usr/share/sdl-ball/leveleditor/gimp-leveleditor/sdlball.xcf
}