summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKozeid2017-07-28 13:52:41 +0200
committerKozeid2017-07-28 13:52:41 +0200
commit7a8c05c2e2ea20ebcfcc8e3aa6024830edf6743a (patch)
tree32284790d10d94908c082b602cce01c26c6e9d30
downloadaur-7a8c05c2e2ea20ebcfcc8e3aa6024830edf6743a.tar.gz
initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD41
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11ee89ae3a63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = sdl-hg
+ pkgdesc = A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard
+ pkgver = 1.2.15.r11056.1138bf8c009a
+ pkgrel = 1
+ url = https://www.libsdl.org
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = alsa-lib
+ makedepends = mesa
+ makedepends = libpulse
+ makedepends = glu
+ makedepends = mercurial
+ depends = glibc
+ depends = libxext
+ depends = libxrender
+ depends = libx11
+ optdepends = alsa-lib: ALSA audio driver
+ optdepends = libpulse: PulseAudio audio driver
+ provides = sdl=1.2.15.r11056.1138bf8c009a
+ conflicts = sdl
+ options = staticlibs
+ source = hg+http://hg.libsdl.org/SDL#branch=SDL-1.2
+ md5sums = SKIP
+
+pkgname = sdl-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f5764862c9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Kozeid <kozeid2@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
+
+_pkgname=sdl
+pkgname=$_pkgname-hg
+_pkgver=1.2.15
+pkgver=1.2.15.r11056.1138bf8c009a
+pkgrel=1
+pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard"
+arch=('i686' 'x86_64')
+url="https://www.libsdl.org"
+license=('LGPL')
+depends=('glibc' 'libxext' 'libxrender' 'libx11')
+makedepends=('alsa-lib' 'mesa' 'libpulse' 'glu' 'mercurial')
+optdepends=('alsa-lib: ALSA audio driver'
+ 'libpulse: PulseAudio audio driver')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+options=('staticlibs')
+source=("hg+http://hg.libsdl.org/SDL#branch=SDL-1.2")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "SDL/"
+ printf "%s.r%s.%s" "$_pkgver" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+build() {
+ cd "SDL/"
+ ./autogen.sh
+ ./configure --prefix=/usr --disable-nasm --enable-alsa \
+ --with-x --disable-rpath --disable-static
+ make
+}
+
+package() {
+ cd "SDL/"
+ make DESTDIR="$pkgdir/" install
+}