summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-11-28 14:13:22 -0500
committerVincent Grande2020-11-28 14:13:22 -0500
commitc6f71f58978599ec609ed7c65598bb05d8587582 (patch)
treeee5e5daa4417e477f4be91e2b454d2cc81e21203
parentba99505736863930f27523d957d8f3d86b648214 (diff)
downloadaur-c6f71f58978599ec609ed7c65598bb05d8587582.tar.gz
disable some build options
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD24
2 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e46729ddba37..9fcf86f1c315 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,7 +14,6 @@ pkgbase = sdl2-minimal-hg
makedepends = libxxf86vm
makedepends = mercurial
makedepends = ninja
- makedepends = hidapi
depends = glibc
depends = libxext
depends = libxrender
@@ -33,6 +32,7 @@ pkgbase = sdl2-minimal-hg
optdepends = wayland-protocols: wayland support
optdepends = hidapi: hidapi support
optdepends = mesa: open source graphics support
+ optdepends = hidapi: modern controller support
provides = sdl2
conflicts = sdl2
conflicts = sdl2-hg
diff --git a/PKGBUILD b/PKGBUILD
index 0f32a82d6060..542c41282db7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ arch=('x86_64')
url="https://www.libsdl.org"
license=('MIT')
depends=('glibc' 'libxext' 'libxrender' 'libx11' 'libgl' 'libxcursor' 'libxxf86vm')
-makedepends=('alsa-lib' 'libxrandr' 'libxinerama' 'libxkbcommon' 'libxss' 'cmake' 'libxxf86vm' 'mercurial' 'ninja' 'hidapi')
+makedepends=('alsa-lib' 'libxrandr' 'libxinerama' 'libxkbcommon' 'libxss' 'cmake' 'libxxf86vm' 'mercurial' 'ninja')
optdepends=('alsa-lib: ALSA audio driver'
'libpulse: PulseAudio audio driver'
'jack: JACK audio driver'
@@ -21,7 +21,8 @@ optdepends=('alsa-lib: ALSA audio driver'
'wayland: wayland support'
'wayland-protocols: wayland support'
'hidapi: hidapi support'
- 'mesa: open source graphics support')
+ 'mesa: open source graphics support'
+ 'hidapi: modern controller support')
source=("hg+https://hg.libsdl.org/SDL#branch=default")
provides=(sdl2)
conflicts=(sdl2 sdl2-hg)
@@ -56,14 +57,31 @@ build() {
-DSDL_STATIC=OFF \
-DSDL_DLOPEN=ON \
-DARTS=OFF \
+ -DARTS_SHARED=OFF \
-DESD=OFF \
+ -DESD_SHARED=OFF \
-DNAS=OFF \
+ -DNAS_SHARED=OFF \
-DALSA=ON \
- -DHIDAPI=ON \
+ -DOSS=OFF
+ -DHIDAPI=OFF \
+ -DHIDAPI_LIBUSB=OFF \
+ -DJOYSTICK=OFF \
+ -DJOYSTICK_VIRTUAL=OFF \
+ -DJOYSTICK_MFI=OFF \
+ -DHAPTIC=OFF \
+ -DSENSOR=OFF \
+ -DSNDIO=OFF \
+ -DSNDIO_SHARED=OFF \
+ -DPULSEAUDIO=OFF \
-DPULSEAUDIO_SHARED=OFF \
-DVIDEO_WAYLAND=ON \
-DRPATH=OFF \
-DCLOCK_GETTIME=ON \
+ -DVIDEO_RPI=OFF \
+ -DIBUS=OFF \
+ -DFCITX=OFF \
+ -DJACK=OFF \
-DJACK_SHARED=OFF
ninja -C build
}