summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChrister Solskogen2021-08-13 09:19:13 +0200
committerChrister Solskogen2021-08-13 09:19:13 +0200
commite6c078308744ba8c1002f9e26a1df2cc0695c3a1 (patch)
tree1f66ec1e92edcdead8c5b8ecf9cb38170547db91
parent9758240cec359cd402720c0b68a97053df957742 (diff)
downloadaur-e6c078308744ba8c1002f9e26a1df2cc0695c3a1.tar.gz
Update to 2.0.16
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb8910bc2dc5..ebef4a29e9e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sdl2-nox
pkgdesc = A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) without X11 support
- pkgver = 2.0.14
+ pkgver = 2.0.16
pkgrel = 1
url = http://www.libsdl.org
arch = x86_64
@@ -16,8 +16,7 @@ pkgbase = sdl2-nox
optdepends = libpulse: PulseAudio audio driver
provides = sdl2
conflicts = sdl2
- source = https://www.libsdl.org/release/SDL2-2.0.14.tar.gz
- sha512sums = ebc482585bd565bf3003fbcedd91058b2183e333b9ea566d2f386da0298ff970645d9d25c1aa4459c7c96e9ea839fd1c5f2da0242a56892865b2e456cdd027ee
+ source = https://www.libsdl.org/release/SDL2-2.0.16.tar.gz
+ sha512sums = ec75ef8526792650c2647b78bb0244f973774418aeae33a2182d90ce696b30acb652f8be9c2012a16c1c5d5622f7630ff2e1eadae27ea3dc78ab47730cf5e62f
pkgname = sdl2-nox
-
diff --git a/PKGBUILD b/PKGBUILD
index e2500642377a..392b7bcc01ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# In order to use this on the Raspberry PI, you must either use the kms or fkms driver.
pkgname=sdl2-nox
-pkgver=2.0.14
+pkgver=2.0.16
pkgrel=1
pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) without X11 support"
arch=('x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -16,21 +16,24 @@ conflicts=('sdl2')
optdepends=('alsa-lib: ALSA audio driver'
'libpulse: PulseAudio audio driver')
source=("https://www.libsdl.org/release/SDL2-${pkgver}.tar.gz")
-sha512sums=('ebc482585bd565bf3003fbcedd91058b2183e333b9ea566d2f386da0298ff970645d9d25c1aa4459c7c96e9ea839fd1c5f2da0242a56892865b2e456cdd027ee')
+sha512sums=('ec75ef8526792650c2647b78bb0244f973774418aeae33a2182d90ce696b30acb652f8be9c2012a16c1c5d5622f7630ff2e1eadae27ea3dc78ab47730cf5e62f')
+
+prepare() {
+ rm -rf build
+ mkdir build
+}
build() {
- cd "SDL2-$pkgver"
- ./configure --prefix=/usr \
+ cd build
+ ../SDL2-$pkgver/configure --prefix=/usr \
--disable-arts --disable-esd --disable-nas \
--enable-pulseaudio-shared --enable-video-kmsdrm \
--without-x --disable-video-wayland --disable-video-rpi
make
}
-
package() {
- cd "SDL2-$pkgver"
- make DESTDIR="$pkgdir" install
- install -Dm644 ../SDL2-$pkgver/COPYING.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd build
+ make install DESTDIR="$pkgdir"
+ install -Dm644 ../SDL2-$pkgver/LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-