summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuiz Silveira2019-08-14 15:59:19 -0300
committerLuiz Silveira2019-08-14 15:59:19 -0300
commit8f03b3c01e7495ace2b4a4bd41999d0b9eeb4a5e (patch)
tree642f373f4018d3234dfef2f9fb21b6b44adde197
downloadaur-8f03b3c01e7495ace2b4a4bd41999d0b9eeb4a5e.tar.gz
first release
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD55
2 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22b9599d7188
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = sdl2-rpi
+ pkgdesc = SDL2 using the accelerated broadcom driver for Raspbery Pi 0, 1, 2 & 3 - fullscreen without X. Also suports the opensource vc4-(f)kms-v3d driver in both standalone mode and in X11.
+ pkgver = 2.0.10
+ pkgrel = 1
+ url = https://www.libsdl.org
+ arch = armv6h
+ arch = armv7h
+ arch = armv8h
+ license = MIT
+ makedepends = alsa-lib
+ makedepends = mesa
+ makedepends = libpulse
+ makedepends = libxrandr
+ makedepends = libxinerama
+ makedepends = wayland
+ makedepends = libxkbcommon
+ makedepends = wayland-protocols
+ makedepends = ibus
+ makedepends = fcitx
+ makedepends = libxss
+ makedepends = cmake
+ makedepends = jack
+ depends = glibc
+ depends = libxext
+ depends = libxrender
+ depends = libx11
+ depends = libgl
+ depends = libxcursor
+ depends = libibus
+ optdepends = alsa-lib: ALSA audio driver
+ optdepends = libpulse: PulseAudio audio driver
+ optdepends = jack: JACK audio driver
+ replaces = sdl2
+ source = https://www.libsdl.org/release/SDL2-2.0.10.tar.gz
+ sha512sums = f49b869362699b3282f6e82920e59c7fac581bcbf955f18a81cc126293c08093a90df7fcb39517cc8bc32708d2213fe645a42b655d6d811c1386efebb3d3c798
+
+pkgname = sdl2-rpi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9ecea8866f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Original archlinux' sdl2 package Maintainer: Sven-Hendrik Haase
+# Raspberry Pi package Maintainer: Luiz Silveira (zertyz @ gmail)
+
+pkgname=sdl2-rpi
+pkgver=2.0.10
+pkgrel=1
+pkgdesc="SDL2 using the accelerated broadcom driver for Raspbery Pi 0, 1, 2 & 3 - fullscreen without X. Also suports the opensource vc4-(f)kms-v3d driver in both standalone mode and in X11."
+arch=('armv6h' 'armv7h' 'armv8h')
+url="https://www.libsdl.org"
+license=('MIT')
+depends=('glibc' 'libxext' 'libxrender' 'libx11' 'libgl' 'libxcursor' 'libibus')
+makedepends=('alsa-lib' 'mesa' 'libpulse' 'libxrandr' 'libxinerama' 'wayland' 'libxkbcommon'
+ 'wayland-protocols' 'ibus' 'fcitx' 'libxss' 'cmake' 'jack')
+optdepends=('alsa-lib: ALSA audio driver'
+ 'libpulse: PulseAudio audio driver'
+ 'jack: JACK audio driver')
+replaces=('sdl2')
+source=("https://www.libsdl.org/release/SDL2-${pkgver}.tar.gz")
+sha512sums=('f49b869362699b3282f6e82920e59c7fac581bcbf955f18a81cc126293c08093a90df7fcb39517cc8bc32708d2213fe645a42b655d6d811c1386efebb3d3c798')
+
+prepare() {
+ cd SDL2-${pkgver}
+
+ mkdir build
+}
+
+build() {
+ cd SDL2-${pkgver}/build
+ PKG_CONFIG_PATH=/opt/vc/lib/pkgconfig LDFLAGS=-pthread cmake -DVIDEO_RPI=ON -DCMAKE_BUILD_TYPE=Release cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DSDL_STATIC=OFF \
+ -DSDL_DLOPEN=ON \
+ -DARTS=OFF \
+ -DESD=OFF \
+ -DNAS=OFF \
+ -DALSA=ON \
+ -DPULSEAUDIO_SHARED=ON \
+ -DVIDEO_WAYLAND=ON \
+ -DRPATH=OFF \
+ -DCLOCK_GETTIME=ON \
+ -DJACK_SHARED=ON
+ make
+}
+
+package() {
+ cd SDL2-${pkgver}/build
+
+ make DESTDIR="${pkgdir}" install
+
+ sed -i "s/libSDL2\.a/libSDL2main.a/g" "$pkgdir"/usr/lib/cmake/SDL2/SDL2Targets-noconfig.cmake
+
+ install -Dm644 ../COPYING.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: