summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedroHLC2021-05-25 22:16:04 -0300
committerPedroHLC2021-05-25 22:16:04 -0300
commitcb1242a4b3f45dd7f8a250f456c944d0f7858036 (patch)
tree240e370c7ed49bd5f88ddca9ab6facd528b6886d
parent07b68f408682347e0316819342275130e61cedd7 (diff)
downloadaur-cb1242a4b3f45dd7f8a250f456c944d0f7858036.tar.gz
Bump to r271; Add glu; Update LICENSE source
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD21
2 files changed, 10 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd1fa63ec239..0606fbba52d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sdl2_compat12-git
pkgdesc = Provides a binary-compatible API for programs written against SDL 1.2, but it uses SDL 2.0 behind the scenes.
- pkgver = r120+.dc55edfe5d2f+
+ pkgver = r271.c71d037
pkgrel = 1
url = https://github.com/libsdl-org/sdl12-compat.git
arch = i686
@@ -9,6 +9,7 @@ pkgbase = sdl2_compat12-git
makedepends = cmake
makedepends = git
depends = sdl2
+ depends = glu
provides = sdl=1.12.15
conflicts = sdl
source = git+https://github.com/libsdl-org/sdl12-compat.git
diff --git a/PKGBUILD b/PKGBUILD
index f6a88e83a790..e994847056c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,23 @@
# Maintainer: Sebastian Meyer <aur@mailhell.seb7.de>
+# Contributor: Pedro H. Lara Campos <root@pedrohlc.com>
_pkgname=sdl2_compat12
pkgname=sdl2_compat12-git
provides=('sdl=1.12.15')
conflicts=('sdl')
-pkgver=r120+.dc55edfe5d2f+
+pkgver=r271.c71d037
pkgrel=1
pkgdesc="Provides a binary-compatible API for programs written against SDL 1.2, but it uses SDL 2.0 behind the scenes."
url=https://github.com/libsdl-org/sdl12-compat.git
arch=('i686' 'x86_64')
license=('ZLIB')
-depends=('sdl2')
+depends=('sdl2' 'glu')
makedepends=('cmake' 'git')
source=('git+https://github.com/libsdl-org/sdl12-compat.git' 'fix-cmakelists.patch' 'fix-srcdir-reference.patch')
sha256sums=('SKIP'
'6b89938e36ceafbe0e5fec87aa03606c20166890ea73320e5fabf4fd2c3ff4b5'
'e59519698276b34277a76746b84c06afe5f21037e3c4a5a8e8f913306f0bd812')
-prepare() {
- cd sdl12-compat
- patch --forward --strip=1 --input="${srcdir}/fix-cmakelists.patch"
- patch --forward --strip=1 --input="${srcdir}/fix-srcdir-reference.patch"
-}
-
pkgver() {
cd sdl12-compat
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
@@ -36,9 +31,9 @@ build() {
package() {
cd "sdl12-compat"
- mkdir -p "$pkgdir/usr/lib"
- mkdir -p "$pkgdir/usr/share/licenses/$_pkgname/"
-
- cp -a libSDL-1.2.so* "$pkgdir/usr/lib"
- cp -a COPYING "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ make DESTDIR="$pkgdir" install
+
+ install -dm755 "$pkgdir/usr/share/licenses/$_pkgname/"
+ install -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}
+