summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmperorPenguin182022-09-28 20:44:24 -0400
committerEmperorPenguin182022-09-28 20:44:24 -0400
commit93cda49947de4774865cd743dd0ed36c00f8d67b (patch)
tree64327de10f0e7a96c4b61dc4769f6bb4e0cd28a5
downloadaur-93cda49947de4774865cd743dd0ed36c00f8d67b.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a069ddfbb8d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = sdl2_fontcache
+ pkgdesc = A generic font caching library
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/grimfang4/SDL_FontCache
+ arch = x86_64
+ license = MIT
+ depends = sdl2_ttf
+ source = git+https://github.com/grimfang4/SDL_FontCache.git
+ sha256sums = SKIP
+
+pkgname = sdl2_fontcache
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a84e75d8b59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Sebastien MacDougall-Landry
+
+pkgname=sdl2_fontcache
+pkgver=1
+pkgrel=1
+pkgdesc='A generic font caching library'
+url='https://github.com/grimfang4/SDL_FontCache'
+source=("git+https://github.com/grimfang4/SDL_FontCache.git")
+arch=('x86_64')
+license=('MIT')
+depends=('sdl2_ttf')
+sha256sums=('SKIP')
+
+build () {
+ cd SDL_FontCache
+ sed -i 's|"SDL.h"|<SDL2/SDL.h>|g' SDL_FontCache.h
+ sed -i 's|"SDL_ttf.h"|<SDL2/SDL_ttf.h>|g' SDL_FontCache.h
+ gcc -O3 -fPIC -shared SDL_FontCache.c -o libSDL2_FontCache.so
+}
+
+package () {
+ cd SDL_FontCache
+ install -Dm755 libSDL2_FontCache.so -t "$pkgdir/usr/lib"
+ install -Dm644 SDL_FontCache.h -t "$pkgdir/usr/include/SDL2"
+}