summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-02-14 02:23:26 -0500
committerVincent Grande2021-02-14 02:23:26 -0500
commit8ecdd97342a189a712c193da7cd36ce986a17464 (patch)
tree9064eb99bd136f7da4e5e95d7e6e36c4d7094790
downloadaur-8ecdd97342a189a712c193da7cd36ce986a17464.tar.gz
initial upload
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d70c59a6f396
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = sdl2_image-minimal-git
+ pkgdesc = A simple library to load images of various formats as SDL surfaces (Version 2)
+ pkgver = 2.0.5
+ pkgrel = 1
+ url = http://www.libsdl.org/projects/SDL_image
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = mercurial
+ depends = sdl2
+ depends = libpng
+ depends = libtiff
+ depends = libjpeg
+ provides = sdl2_image
+ conflicts = sdl2_image
+ source = git+https://github.com/libsdl-org/SDL_image
+ sha512sums = SKIP
+
+pkgname = sdl2_image-minimal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36301b6aeda2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+
+pkgname=sdl2_image-minimal-git
+pkgver=2.0.5
+pkgrel=1
+pkgdesc="A simple library to load images of various formats as SDL surfaces (Version 2)"
+arch=('x86_64')
+url="http://www.libsdl.org/projects/SDL_image"
+license=('MIT')
+depends=('sdl2' 'libpng' 'libtiff' 'libjpeg')
+makedepends=('cmake' 'mercurial')
+provides=(sdl2_image)
+conflicts=(sdl2_image)
+source=(git+https://github.com/libsdl-org/SDL_image)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd SDL_image
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+
+build() {
+ cd SDL_image
+
+ ./autogen.sh
+ ./configure --disable-static --prefix=/usr \
+ --disable-jpg-shared \
+ --disable-png-shared \
+ --disable-tif-shared \
+ --disable-webp-shared \
+ --disable-webp \
+ --disable-webpdec
+ make
+}
+
+package() {
+ cd SDL_image
+
+ make DESTDIR="${pkgdir}/" install
+ install -Dm644 COPYING.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}