summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2016-02-23 02:34:31 +0100
committerCarsten Teibes2016-02-23 02:34:31 +0100
commitb30cc4f01e5292751f4eddcad0985c2de5ce380f (patch)
treebd94be4ac023392aa2076710488ab99837f6637a
downloadaur-b30cc4f01e5292751f4eddcad0985c2de5ce380f.tar.gz
[add] sdl2_mixer-hg
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD52
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57db4e1fa6f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = sdl2_mixer-hg
+ pkgdesc = A simple multi-channel audio mixer (Version 2, development version)
+ pkgver = 2.0.1.r8.d9b3684ca715
+ pkgrel = 1
+ url = http://libsdl.org/projects/SDL_mixer
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = mercurial
+ makedepends = fluidsynth
+ depends = sdl2-hg
+ depends = libvorbis
+ depends = libmodplug
+ depends = libmad
+ depends = flac
+ optdepends = fluidsynth: MIDI software synth, replaces built-in timidity
+ provides = sdl2_mixer
+ conflicts = sdl2_mixer
+ conflicts = sdl2-mixer-hg
+ source = sdl2_mixer-hg::hg+http://hg.libsdl.org/SDL_mixer
+ md5sums = SKIP
+
+pkgname = sdl2_mixer-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f5e406706c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=sdl2_mixer-hg
+pkgver=2.0.1.r8.d9b3684ca715
+pkgrel=1
+pkgdesc="A simple multi-channel audio mixer (Version 2, development version)"
+arch=('i686' 'x86_64')
+url="http://libsdl.org/projects/SDL_mixer"
+license=('MIT')
+depends=('sdl2-hg' 'libvorbis' 'libmodplug' 'libmad' 'flac')
+makedepends=('mercurial' 'fluidsynth')
+optdepends=('fluidsynth: MIDI software synth, replaces built-in timidity')
+provides=('sdl2_mixer')
+conflicts=('sdl2_mixer' 'sdl2-mixer-hg')
+source=($pkgname::'hg+http://hg.libsdl.org/SDL_mixer')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+
+ local _lasttag=$(hg tags -q | sort -r | grep release- | head -n1)
+ local _commits=$(hg log --template "{node}\n" -r $_lasttag:tip | wc -l)
+ printf "%s.r%s.%s" "${_lasttag/release-}" "$_commits" "$(hg identify -i)"
+}
+
+prepare() {
+ cd $pkgname
+
+ # fix timidity path
+ sed -e "s|/etc/timidity|/etc/timidity++|g" \
+ -e "s|/etc/timidity++.cfg|/etc/timidity++/timidity.cfg|g" \
+ -i timidity/config.h
+}
+
+build() {
+ cd $pkgname
+
+ ./autogen.sh
+ ./configure --disable-static --prefix=/usr \
+ --enable-music-mp3-mad-gpl --disable-music-mp3-smpeg # use libmad instead of smpeg2
+ make
+}
+
+package() {
+ cd $pkgname
+
+ make DESTDIR="$pkgdir/" install install-bin
+ mv "$pkgdir"/usr/bin/playwave{,2}
+ mv "$pkgdir"/usr/bin/playmus{,2}
+
+ install -Dm644 COPYING.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}