summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2021-06-17 01:15:35 +0200
committerCarsten Teibes2021-06-17 01:15:35 +0200
commit453bf5822f9252f1e85b1df0d84930923593bdbb (patch)
tree3d60bfea17bc5c89a6683071664742d10a0c6241
parent8a061a04c4c73d98b348c6ec6a5583483f7e435e (diff)
downloadaur-453bf5822f9252f1e85b1df0d84930923593bdbb.tar.gz
[upd] Small cleanup
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD23
2 files changed, 10 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcf00f90d4b8..e9e504743ea0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sdl2_sound-hg
pkgdesc = A library to decode several popular sound file formats (Version 2, development version)
- pkgver = 1.0.3.r105.9262f9205898
+ pkgver = 1.0.3.r275.85186703b413
pkgrel = 1
url = http://icculus.org/SDL_sound/
arch = i686
@@ -14,4 +14,3 @@ pkgbase = sdl2_sound-hg
md5sums = SKIP
pkgname = sdl2_sound-hg
-
diff --git a/PKGBUILD b/PKGBUILD
index 90bdf26cb555..824c14327d2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=sdl2_sound-hg
-pkgver=1.0.3.r105.9262f9205898
+pkgver=1.0.3.r275.85186703b413
pkgrel=1
pkgdesc="A library to decode several popular sound file formats (Version 2, development version)"
arch=('i686' 'x86_64')
@@ -23,24 +23,19 @@ pkgver() {
printf "%s.r%s.%s" "${_lasttag/release-}" "$_commits" "$_hash"
}
-prepare() {
- rm -rf build
- mkdir build
-
- # fixup an oversight (wrong path)
- sed 's|FILES SDL_sound.h|FILES src/SDL_sound.h|' -i ${pkgname%-*}/CMakeLists.txt
-}
-
build() {
- cd build
-
- cmake ../${pkgname%-*} -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr \
+ rm -rf build
+ cmake -Bbuild ${pkgname%-*} \
+ -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DSDLSOUND_BUILD_STATIC=FALSE \
-DSDL2_INCLUDE_DIRS=/usr/include/SDL2 -DSDL2_LIBRARIES=/usr/lib/libSDL2.so
- make
+ cmake --build build
}
package() {
- make -C build DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir/" cmake --install build
+
+ # handle conflict with sdl_sound
+ mv "$pkgdir"/usr/bin/playsound{,-sdl2}
# docs
install -d "$pkgdir"/usr/share/doc/${pkgname%-*}