summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-01-11 09:39:00 +0100
committerCarsten Teibes2014-01-11 09:39:00 +0100
commita470cdbfdbcec144d72a44fa0f7462f29a651526 (patch)
treeba8828eaabb02450944d58dcc24f374259a85c3f
downloadaur-a470cdbfdbcec144d72a44fa0f7462f29a651526.tar.gz
[add] sdl_sound-hg
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
-rw-r--r--physfs-renamed-export.patch27
3 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7302e2e8a66
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = sdl_sound-hg
+ pkgdesc = A library to decode several popular sound file formats (development version)
+ pkgver = r596.719dade41745
+ pkgrel = 1
+ url = http://icculus.org/SDL_sound/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = sdl
+ depends = libmodplug
+ depends = libvorbis
+ depends = flac
+ depends = speex
+ provides = sdl_sound
+ conflicts = sdl_sound
+ source = sdl_sound::hg+http://hg.icculus.org/icculus/SDL_sound
+ source = physfs-renamed-export.patch
+ sha256sums = SKIP
+ sha256sums = d7bd96390d9bc877c0204922c7c4666cadfdccc5e6c0cfcf9477d113377f5d10
+
+pkgname = sdl_sound-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e962be673b33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+_name=sdl_sound
+pkgname=$_name-hg
+pkgver=r596.719dade41745
+pkgrel=1
+pkgdesc="A library to decode several popular sound file formats (development version)"
+arch=('i686' 'x86_64')
+url="http://icculus.org/SDL_sound/"
+license=('LGPL')
+depends=('sdl' 'libmodplug' 'libvorbis' 'flac' 'speex')
+conflicts=("$_name")
+provides=("$_name")
+source=($_name::"hg+http://hg.icculus.org/icculus/SDL_sound"
+ 'physfs-renamed-export.patch')
+sha256sums=('SKIP'
+ 'd7bd96390d9bc877c0204922c7c4666cadfdccc5e6c0cfcf9477d113377f5d10')
+
+pkgver() {
+ cd $_name
+
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+prepare() {
+ cd $_name
+
+ # fix deprecated physfs declaration
+ patch -Np1 < ../physfs-renamed-export.patch
+}
+
+build() {
+ cd $_name
+
+ ./bootstrap
+ ./configure --prefix=/usr --disable-static --disable-mikmod
+ make
+}
+
+package() {
+ make -C $_name DESTDIR="$pkgdir/" install
+}
diff --git a/physfs-renamed-export.patch b/physfs-renamed-export.patch
new file mode 100644
index 000000000000..316d165c71df
--- /dev/null
+++ b/physfs-renamed-export.patch
@@ -0,0 +1,27 @@
+diff -ru SDL_sound.orig/playsound/physfsrwops.h SDL_sound/playsound/physfsrwops.h
+--- SDL_sound.orig/playsound/physfsrwops.h 2014-01-11 06:28:35.494936000 +0100
++++ SDL_sound/playsound/physfsrwops.h 2014-01-11 06:31:38.315675483 +0100
+@@ -29,6 +29,11 @@
+ extern "C" {
+ #endif
+
++/* renamed in physfs dev, add alias */
++#ifdef PHYSFS_DECL
++#define __EXPORT__ PHYSFS_DECL
++#endif
++
+ /**
+ * Open a platform-independent filename for reading, and make it accessible
+ * via an SDL_RWops structure. The file will be closed in PhysicsFS when the
+@@ -77,6 +82,11 @@
+ */
+ __EXPORT__ SDL_RWops *PHYSFSRWOPS_makeRWops(PHYSFS_file *handle);
+
++/* renamed in physfs dev, remove alias */
++#ifdef PHYSFS_DECL
++#undef __EXPORT__
++#endif
++
+ #ifdef __cplusplus
+ }
+ #endif