diff options
author | Rod Kay | 2022-11-27 13:55:14 +1100 |
---|---|---|
committer | Rod Kay | 2022-11-27 13:55:14 +1100 |
commit | 2662083d212d2dd83a36fe2e6eac2e11b0f0b007 (patch) | |
tree | 84a0ea2e75007bb3b6e2d492f37dce58bbcf11d6 | |
parent | 4952cb8dcf1d252c5b7e65b491bac8529f04bd1a (diff) | |
download | aur-2662083d212d2dd83a36fe2e6eac2e11b0f0b007.tar.gz |
Update to version '2.5.6'.
-rw-r--r-- | .SRCINFO | 12 | ||||
-rw-r--r-- | PKGBUILD | 26 | ||||
-rw-r--r-- | patch-sdl-video-palettes.ads | 11 | ||||
-rw-r--r-- | patch-sdl-video-pixel_formats.ads | 12 |
4 files changed, 10 insertions, 51 deletions
@@ -1,7 +1,7 @@ pkgbase = sdlada pkgdesc = An Ada binding to SDL - pkgver = 2.5.3 - pkgrel = 2 + pkgver = 2.5.6 + pkgrel = 1 url = https://github.com/Lucretia/sdlada/ arch = i686 arch = x86_64 @@ -9,11 +9,7 @@ pkgbase = sdlada depends = gcc-ada depends = sdl2_ttf depends = sdl2_image - source = https://github.com/Lucretia/sdlada/archive/v2.5.3.tar.gz - source = patch-sdl-video-pixel_formats.ads - source = patch-sdl-video-palettes.ads - md5sums = 8d0245cb6c03db3ed136c012d4cc9055 - md5sums = db308de4a3297e497415b89e0aadbed4 - md5sums = 0ec6787e90fe1022270a78f3b5320e42 + source = https://github.com/Lucretia/sdlada/archive/v2.5.6.tar.gz + sha256sums = 15431f8475d1957f8a60e790c46051e95189b1fd99798724d2f659d6827ba8eb pkgname = sdlada @@ -1,8 +1,8 @@ -# Maintainer: Rod Kay <rodakay5 at gnmail.com +# Maintainer: Rod Kay <rodakay5 at gnmail.com> pkgname=sdlada -pkgver=2.5.3 -pkgrel=2 +pkgver=2.5.6 +pkgrel=1 pkgdesc="An Ada binding to SDL" arch=('i686' 'x86_64') @@ -11,22 +11,8 @@ license=('zlib') depends=("gcc-ada" "sdl2_ttf" "sdl2_image") -source=(https://github.com/Lucretia/sdlada/archive/v$pkgver.tar.gz - patch-sdl-video-pixel_formats.ads - patch-sdl-video-palettes.ads) - -md5sums=('8d0245cb6c03db3ed136c012d4cc9055' - 'db308de4a3297e497415b89e0aadbed4' - '0ec6787e90fe1022270a78f3b5320e42') - - -prepare() -{ - cd $srcdir/$pkgname-$pkgver - - patch -Np0 -i ../patch-sdl-video-pixel_formats.ads - patch -Np0 -i ../patch-sdl-video-palettes.ads -} +source=(https://github.com/Lucretia/sdlada/archive/v$pkgver.tar.gz) +sha256sums=('15431f8475d1957f8a60e790c46051e95189b1fd99798724d2f659d6827ba8eb') build() @@ -44,4 +30,4 @@ package() cd build/gnat make SDL_PLATFORM=linux SDL_BUILD=static SDL_MODE=release DESTDIR=$pkgdir/usr install -} +}
\ No newline at end of file diff --git a/patch-sdl-video-palettes.ads b/patch-sdl-video-palettes.ads deleted file mode 100644 index e3e2643493d6..000000000000 --- a/patch-sdl-video-palettes.ads +++ /dev/null @@ -1,11 +0,0 @@ ---- ./src/sdl-video-palettes.ads 2020-06-17 01:27:26.000000000 +1000 -+++ ./src/sdl-video-palettes.ads-new 2021-08-15 01:13:17.306319118 +1000 -@@ -121,7 +121,7 @@ - Data : Internal_Palette_Access; - end record; - -- type Palette_Constant_Access is access constant Palette; -+ type Palette_Constant_Access is access constant Palette'Class; - - type Cursor is - record diff --git a/patch-sdl-video-pixel_formats.ads b/patch-sdl-video-pixel_formats.ads deleted file mode 100644 index 56444958ed4a..000000000000 --- a/patch-sdl-video-pixel_formats.ads +++ /dev/null @@ -1,12 +0,0 @@ ---- ./src/sdl-video-pixel_formats.ads 2020-06-17 01:27:26.000000000 +1000 -+++ ./src/sdl-video-pixel_formats.ads-new 2021-08-15 01:06:01.298705154 +1000 -@@ -653,8 +653,7 @@ - - -- This is mainly padding to make sure the record size matches what is expected from C. - Private_Part : Private_Pixel_Format; -- end record with -- Convention => C; -+ end record; - - -- TODO: Possibly change this to a controlled type. - type Pixel_Format_Access is access all Pixel_Format with |