diff options
author | Rod Kay | 2016-06-05 13:46:12 +1000 |
---|---|---|
committer | Rod Kay | 2016-06-05 13:46:12 +1000 |
commit | aebc442d24161d862b44bdfcad277a700802cf10 (patch) | |
tree | fec96660313f6a00863f99c2db35073b1971abf1 | |
parent | 93f9fd32dd5620f8553efc645ae1420db6e64a75 (diff) | |
download | aur-aebc442d24161d862b44bdfcad277a700802cf10.tar.gz |
Updated to version '2.1.7'.
-rw-r--r-- | .SRCINFO | 10 | ||||
-rw-r--r-- | PKGBUILD | 32 | ||||
-rw-r--r-- | patch-makefile | 19 |
3 files changed, 43 insertions, 18 deletions
@@ -1,6 +1,8 @@ +# Generated by mksrcinfo v8 +# Sun Jun 5 03:45:40 UTC 2016 pkgbase = sdlada pkgdesc = An Ada binding to SDL - pkgver = 2.1.0 + pkgver = 2.1.7 pkgrel = 1 url = https://github.com/Lucretia/sdlada/ arch = i686 @@ -8,8 +10,10 @@ pkgbase = sdlada license = zlib depends = gcc-ada depends = sdl2 - source = https://github.com/Lucretia/sdlada/archive/v2.1.0.tar.gz - md5sums = 24d5f721af23dc085cb43938e04e3607 + source = https://github.com/Lucretia/sdlada/archive/v2.1.7.tar.gz + source = patch-makefile + md5sums = 255a57dc59d250af12dbe3cb7be76e58 + md5sums = 43906f6de67f33578375fe83468073e1 pkgname = sdlada @@ -1,7 +1,7 @@ # Contributor: Rod Kay <charlie5 on #ada at freenode.net> pkgname=sdlada -pkgver=2.1.0 +pkgver=2.1.7 pkgrel=1 pkgdesc="An Ada binding to SDL" @@ -11,33 +11,35 @@ license=('zlib') depends=("gcc-ada" "sdl2") -source=(https://github.com/Lucretia/sdlada/archive/v2.1.0.tar.gz) -md5sums=('24d5f721af23dc085cb43938e04e3607') +source=(https://github.com/Lucretia/sdlada/archive/v2.1.7.tar.gz + patch-makefile) +md5sums=('255a57dc59d250af12dbe3cb7be76e58' + '43906f6de67f33578375fe83468073e1') -build() +prepare() { cd $srcdir/$pkgname-$pkgver - make SDL_PLATFORM=linux SDL_BUILD=static SDL_MODE=release + patch -p0 -i ../patch-makefile } -package() +build() { cd $srcdir/$pkgname-$pkgver + cd build/gnat + + make -j1 SDL_PLATFORM=linux SDL_BUILD=static SDL_MODE=release +} - SDL_PLATFORM=linux - SDL_BUILD=static - SDL_MODE=release - gprinstall --prefix=$pkgdir/usr \ - --project-subdir=$pkgdir/usr/lib/gnat \ - --build-name=$SDL_MODE.$SDL_BUILD -p \ - -XSDL_BUILD=$SDL_BUILD -XSDL_MODE=$SDL_MODE -XSDL_PLATFORM=$SDL_PLATFORM \ - -Psdlada.gpr +package() +{ + cd $srcdir/$pkgname-$pkgver + cd build/gnat - install --mode=0644 sdl_version.gpr $pkgdir/usr/lib/gnat + make SDL_PLATFORM=linux SDL_BUILD=static SDL_MODE=release DESTDIR=$pkgdir install } diff --git a/patch-makefile b/patch-makefile new file mode 100644 index 000000000000..60207553d077 --- /dev/null +++ b/patch-makefile @@ -0,0 +1,19 @@ +*** build/gnat/makefile 2016-05-30 05:04:36.000000000 +1000 +--- build/gnat/makefile-new 2016-06-05 13:35:37.235667615 +1000 +*************** +*** 121,127 **** + .PHONY: install + + install: all +! $(GPRINSTALL) --prefix=$(DESTDIR)/sdlada --build-name=$(SDL_MODE).$(SDL_BUILD) -p -f \ + -XSDL_BUILD=$(SDL_BUILD) -XSDL_MODE=$(SDL_MODE) -XSDL_PLATFORM=$(SDL_PLATFORM) \ + -Psdlada.gpr + +--- 121,127 ---- + .PHONY: install + + install: all +! $(GPRINSTALL) --prefix=$(DESTDIR)/usr --build-name=$(SDL_MODE).$(SDL_BUILD) -p -f \ + -XSDL_BUILD=$(SDL_BUILD) -XSDL_MODE=$(SDL_MODE) -XSDL_PLATFORM=$(SDL_PLATFORM) \ + -Psdlada.gpr + |