summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Doege2016-07-30 00:18:05 +0200
committerMartin Doege2016-07-30 00:18:05 +0200
commitd5b9e38c02032bae3c39524c4260db689a33ff23 (patch)
treecf75c0be234580cf2ba36464c24aa28bb2eedfbd
downloadaur-d5b9e38c02032bae3c39524c4260db689a33ff23.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--sdlmame-cheats.install5
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73145f60f14e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Jul 29 22:14:32 UTC 2016
+pkgbase = sdlmame-cheats
+ pkgdesc = Official XML Cheat Collection for MAME
+ pkgver = 0.174
+ pkgrel = 1
+ url = http://www.mamecheat.co.uk/
+ install = sdlmame-cheats.install
+ arch = any
+ license = unknown
+ makedepends = unzip
+ depends = sdlmame>=0.145u1
+ optdepends = sdlmame>=0.174: this package is best used with an up-to-date version of sdlmame.
+ source = http://cheat.retrogames.com/download/cheat0174.zip
+ sha1sums = SKIP
+
+pkgname = sdlmame-cheats
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..620c0e9afe64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Martin C. Doege <mdoege at compuserve dot com>
+# Contributor: Anton Shestakov <engored*ya.ru>
+# Contributor: listx <linusarver <at> gmail <dot> com>
+
+pkgname=sdlmame-cheats
+pkgver=0.174
+pkgrel=1
+_srcver=0174
+pkgdesc='Official XML Cheat Collection for MAME'
+url='http://www.mamecheat.co.uk/'
+license=('unknown')
+arch=('any')
+depends=('sdlmame>=0.145u1') # XML cheat engine since 0.127, 7z support since 0.145u1
+optdepends=("sdlmame>=$pkgver: this package is best used with an up-to-date version of sdlmame.")
+makedepends=('unzip')
+source=("http://cheat.retrogames.com/download/cheat${_srcver}.zip")
+install=sdlmame-cheats.install
+sha1sums=('SKIP')
+
+build() {
+ unzip -of "cheat${_srcver}.zip"
+}
+
+package() {
+ install -Dm644 cheat.7z "$pkgdir/usr/share/sdlmame/cheat.7z"
+ install -Dm644 cheat.txt "$pkgdir/usr/share/doc/sdlmame-cheats/cheat.txt"
+ install -Dm644 "!README_FIRST!!.txt" "$pkgdir/usr/share/doc/sdlmame-cheats/!README_FIRST!!.txt"
+}
+
diff --git a/sdlmame-cheats.install b/sdlmame-cheats.install
new file mode 100644
index 000000000000..873e38b8e1c0
--- /dev/null
+++ b/sdlmame-cheats.install
@@ -0,0 +1,5 @@
+post_install()
+{
+ echo "Add this line to ~/.mame/mame.ini:"
+ echo " cheat 1"
+}