summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072018-04-08 18:41:52 +0200
committersL1pKn072018-04-08 18:41:52 +0200
commit876f6aa743332f63c1be42a3cbda90f27835040d (patch)
tree9557fcd557df813e8d332b1f4657b233f9aa4160
parentd38e85ab93e3ec735e21f07156285c33aa0ad73b (diff)
downloadaur-876f6aa743332f63c1be42a3cbda90f27835040d.tar.gz
Update to 0.196
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD70
-rw-r--r--sdlmame-wout-toolkits.install2
-rw-r--r--sdlmame.sh72
4 files changed, 81 insertions, 76 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3e7e9200006..48de25440693 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jan 11 14:49:25 UTC 2018
+# Sun Apr 8 16:40:32 UTC 2018
pkgbase = sdlmame-wout-toolkits
pkgdesc = A port of the popular Multiple Arcade Machine Emulator using SDL with OpenGL support. Without Qt toolkit
- pkgver = 0.193
+ pkgver = 0.196
pkgrel = 1
url = http://mamedev.org
install = sdlmame-wout-toolkits.install
@@ -11,8 +11,9 @@ pkgbase = sdlmame-wout-toolkits
makedepends = nasm
makedepends = mesa
makedepends = glu
+ makedepends = glm
makedepends = wget
- makedepends = python
+ makedepends = python-sphinx
depends = sdl2_ttf
depends = alsa-lib
depends = lua
@@ -25,10 +26,10 @@ pkgbase = sdlmame-wout-toolkits
depends = libutf8proc
conflicts = sdlmame
conflicts = sdlmamefamily-tools
- source = https://github.com/mamedev/mame/archive/mame0193.tar.gz
+ source = https://github.com/mamedev/mame/archive/mame0196.tar.gz
source = sdlmame.sh
- sha256sums = 6b5e90b602befbcad2b6989b1e930d0ff6e537dc901f7b1615a3e6deec2207a2
- sha256sums = 201e9cc3d0d7397e15a4aaf7477f8b32a379a9ba2134b94180cdaf2067d1f859
+ sha256sums = fc4436a23d7f2ef0b3c3f600c00745bc468541d0d29bcd3a1e0c599c5c02df7f
+ sha256sums = d0289344e2260411965a56290cb4744963f48961326ce7f41b90f75f4221bb42
pkgname = sdlmame-wout-toolkits
diff --git a/PKGBUILD b/PKGBUILD
index d7153009c9e0..d22d5bbd9d3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Based On: Sergej Pupykin <pupykin.s+arch@gmail.com>
pkgname=sdlmame-wout-toolkits
-pkgver=0.193
+pkgver=0.196
pkgrel=1
pkgdesc="A port of the popular Multiple Arcade Machine Emulator using SDL with OpenGL support. Without Qt toolkit"
url='http://mamedev.org'
@@ -23,14 +23,15 @@ depends=('sdl2_ttf'
makedepends=('nasm'
'mesa'
'glu'
+ 'glm'
'wget'
- 'python'
+ 'python-sphinx'
)
source=("https://github.com/mamedev/mame/archive/mame${pkgver/./}.tar.gz"
'sdlmame.sh'
)
-sha256sums=('6b5e90b602befbcad2b6989b1e930d0ff6e537dc901f7b1615a3e6deec2207a2'
- '201e9cc3d0d7397e15a4aaf7477f8b32a379a9ba2134b94180cdaf2067d1f859'
+sha256sums=('fc4436a23d7f2ef0b3c3f600c00745bc468541d0d29bcd3a1e0c599c5c02df7f'
+ 'd0289344e2260411965a56290cb4744963f48961326ce7f41b90f75f4221bb42'
)
install=sdlmame-wout-toolkits.install
@@ -55,42 +56,53 @@ build() {
USE_SYSTEM_LIB_PORTMIDI=1 \
USE_SYSTEM_LIB_PORTAUDIO=1 \
USE_SYSTEM_LIB_UTF8PROC=1 \
- USE_SYSTEM_LIB_SQLITE3=1
+ USE_SYSTEM_LIB_SQLITE3=1 \
+ USE_SYSTEM_LIB_GLM=1
+
}
package() {
cd "mame-mame${pkgver/./}"
# Install the sdlmame script
- install -Dm755 ../sdlmame.sh "${pkgdir}/usr/bin/sdlmame"
+ install -Dm755 "${srcdir}/sdlmame.sh" "${pkgdir}/usr/bin/sdlmame"
# Install the applications and the UI font in /usr/share
- install -Dm755 "mame64" "${pkgdir}/usr/share/sdlmame/sdlmame"
-
- # Install the applications
- install -Dm755 castool "${pkgdir}/usr/bin/castool"
- install -Dm755 chdman "${pkgdir}/usr/bin/chdman"
- install -Dm755 floptool "${pkgdir}/usr/bin/floptool"
- install -Dm755 imgtool "${pkgdir}/usr/bin/imgtool"
- install -Dm755 jedutil "${pkgdir}/usr/bin/jedutil"
- install -Dm755 ldresample "${pkgdir}/usr/bin/ldresample"
- install -Dm755 ldverify "${pkgdir}/usr/bin/ldverify"
- install -Dm755 nltool "${pkgdir}/usr/bin/nltool"
- install -Dm755 nlwav "${pkgdir}/usr/bin/nlwav"
- install -Dm755 pngcmp "${pkgdir}/usr/bin/pngrep"
- install -Dm755 regrep "${pkgdir}/usr/bin/regrep"
- install -Dm755 romcmp "${pkgdir}/usr/bin/romcmp"
- install -Dm755 split "${pkgdir}/usr/bin/splitmamerom"
- install -Dm755 src2html "${pkgdir}/usr/bin/src2html"
- install -Dm755 srcclean "${pkgdir}/usr/bin/srcclean"
- install -Dm755 unidasm "${pkgdir}/usr/bin/unidasm"
+ install -Dm755 mame64 "${pkgdir}/usr/share/sdlmame/sdlmame"
+ _apps=('castool'
+ 'chdman'
+ 'floptool'
+ 'imgtool'
+ 'jedutil'
+ 'ldresample'
+ 'ldverify'
+ 'nltool'
+ 'nlwav'
+ 'pngcmp'
+ 'regrep'
+ 'romcmp'
+ 'split'
+ 'src2html'
+ 'srcclean'
+ 'unidasm'
+ )
+ for i in "${_apps[@]}"; do install -Dm755 "${i}" "${pkgdir}/usr/share/sdlmame/${i}"; done
# Install the extra bits
- for i in artwork bgfx hash hlsl ini keymaps language plugins; do
- for e in $(find ${i} -type f); do install -Dm644 "${e}" ${pkgdir}/usr/share/sdlmame/${e}; done
- done
+ _extra=('artwork'
+ 'bgfx'
+ 'hash'
+ 'hlsl'
+ 'ini'
+ 'keymaps'
+ 'language'
+ 'plugins'
+ 'roms'
+ )
+ for i in $(find ${_extra[@]} -type f); do install -Dm644 "${i}" "${pkgdir}/usr/share/sdlmame/${i}"; done
install -d "${pkgdir}/usr/share/sdlmame/shader"
install -m644 src/osd/modules/opengl/shader/glsl*.*h "${pkgdir}/usr/share/sdlmame/shader/"
+ install -Dm644 uismall.bdf "${pkgdir}/usr/share/sdlmame/fonts/uismall.bdf"
# Install man
(cd docs/man/; for i in $(find . -type f -name '*.1'); do install -Dm644 "${i}" "${pkgdir}/usr/share/man/man1/${i}"; done)
@@ -100,5 +112,5 @@ package() {
install -Dm644 docs/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# documentation
- (cd docs; for i in $(find . -maxdepth 1 -type f); do install -Dm644 "${i}" "${pkgdir}/usr/share/doc/${pkgname}/${i}"; done)
+ (cd docs; make BUILDDIR="${pkgdir}/usr/share/doc/${pkgname}" html)
}
diff --git a/sdlmame-wout-toolkits.install b/sdlmame-wout-toolkits.install
index ceda91ade1a5..ceb6994be78f 100644
--- a/sdlmame-wout-toolkits.install
+++ b/sdlmame-wout-toolkits.install
@@ -11,7 +11,7 @@ ${green}==>${all_off} ${bold}SDLMAME has been updated.${all_off}
${bold}you must delete all .cfg files${all_off} and ${bold}re-configure your controllers${all_off}.
You should also run:
- '# ${bold}sdlmame --newini${all_off}'
+ '$ ${bold}sdlmame --newini${all_off}'
to force the script to create a new ini
file with default settings at '${bold}~/.mame/mame.ini${all_off}'
diff --git a/sdlmame.sh b/sdlmame.sh
index 716f6d53e9b7..d816389f09ed 100644
--- a/sdlmame.sh
+++ b/sdlmame.sh
@@ -3,59 +3,51 @@
# Create a variable equal to $HOME that will be used later in the ini creation
home=('$HOME')
+_run() {
+ /usr/share/sdlmame/sdlmame \
+ -artpath "$home/.mame/artwork;/usr/share/sdlmame/artwork" \
+ -ctrlrpath "$home/.mame/ctrlr;/usr/share/sdlmame/ctrlr" \
+ -inipath "$home/.mame/ini;/usr/share/sdlmame/ini" \
+ -fontpath "$home/.mame/fonts;/usr/share/sdlmame/fonts" \
+ -hashpath "$home/.mame/hash;/usr/share/sdlmame/hash" \
+ -pluginspath "$home/.mame/plugins;/usr/share/sdlmame/plugins" \
+ -rompath "$home/.mame/roms;/usr/share/sdlmame/roms" \
+ -bgfx_path "/usr/share/sdlmame/bgfx" \
+ -languagepath "/usr/share/sdlmame/language" \
+ -swpath "/usr/share/sdlmame/software" \
+ -cfg_directory "$home/.mame/cfg" \
+ -cheatpath "$home/.mame/cheat" \
+ -comment_directory "$home/.mame/comments" \
+ -crosshairpath "$home/.mame/crosshair" \
+ -diff_directory "$home/.mame/diff" \
+ -input_directory "$home/.mame/input" \
+ -nvram_directory "$home/.mame/nvram" \
+ -samplepath "$home/.mame/samples"\
+ -snapshot_directory "$home/.mame/snapshot" \
+ -state_directory "$home/.mame/state" \
+ -video opengl \
+ -createconfig
+}
+
if [ "$1" != "" ] && [ "$1" = "--newini" ]; then
echo "Rebuilding the ini file at $HOME/.mame/mame.ini"
echo "Modify this file for permanent changes to your SDLMAME"
echo "options and paths before running SDLMAME again."
- cd $HOME/.mame
+ cd "$HOME/.mame"
if [ -e mame.ini ]; then
echo "Your old ini file has been renamed to mameini.bak"
mv mame.ini mameini.bak
fi
- /usr/share/sdlmame/sdlmame \
- -artpath "$home/.mame/artwork;artwork" \
- -ctrlrpath "$home/.mame/ctrlr;ctrlr" \
- -cheatpath "$home/.mame/cheat" \
- -crosshairpath "$home/.mame/crosshair" \
- -hashpath "$home/.mame/hash;hash" \
- -inipath $home/.mame/ini \
- -rompath $home/.mame/roms \
- -samplepath $home/.mame/samples \
- -cfg_directory $home/.mame/cfg \
- -comment_directory $home/.mame/comments \
- -diff_directory $home/.mame/diff \
- -input_directory $home/.mame/inp \
- -nvram_directory $home/.mame/nvram \
- -snapshot_directory $home/.mame/snap \
- -state_directory $home/.mame/sta \
- -video opengl \
- -createconfig
+ _run
elif [ ! -e $HOME/.mame ]; then
echo "Running SDLMAME for the first time..."
echo "Creating an ini file for SDLMAME at $HOME/.mame/mame.ini"
echo "Modify this file for permanent changes to your SDLMAME"
echo "options and paths before running SDLMAME again."
- mkdir $HOME/.mame
- mkdir $HOME/.mame/{artwork,cfg,cheat,comments,crosshair,ctrlr,diff,hash,ini,inp,nvram,samples,snap,sta,roms}
- cd $HOME/.mame
- /usr/share/sdlmame/sdlmame \
- -artpath "$home/.mame/artwork;artwork" \
- -ctrlrpath "$home/.mame/ctrlr;ctrlr" \
- -cheatpath "$home/.mame/cheat" \
- -crosshairpath "$home/.mame/crosshair" \
- -hashpath "$home/.mame/hash;hash" \
- -inipath $home/.mame/ini \
- -rompath $home/.mame/roms \
- -samplepath $home/.mame/samples \
- -cfg_directory $home/.mame/cfg \
- -comment_directory $home/.mame/comments \
- -diff_directory $home/.mame/diff \
- -input_directory $home/.mame/inp \
- -nvram_directory $home/.mame/nvram \
- -snapshot_directory $home/.mame/snap \
- -state_directory $home/.mame/sta \
- -video opengl \
- -createconfig
+ mkdir "$HOME/.mame"
+ mkdir "$HOME/.mame"/{artwork,cfg,cheat,comments,crosshair,ctrlr,diff,fonts,hash,ini,input,nvram,plugins,samples,snapshot,state,roms}
+ cd "$HOME/.mame"
+ _run
else
cd /usr/share/sdlmame
./sdlmame "$@"