summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-14 16:20:41 +0100
committersL1pKn072019-03-14 16:20:41 +0100
commita48423f670840c511d2388034be2018a3ef778ae (patch)
treed852c6ef9eae7dcfba6be3af988595d24c7c2bf6
parent164d0cba75ec0f2ebbef1f42bc5d190301586f32 (diff)
downloadaur-a48423f670840c511d2388034be2018a3ef778ae.tar.gz
think better, i've move the shared/config files from ~/.mame to ~/.config/mame and ~/.local/share/mame. now respect the XDG specs
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--mame.sh58
3 files changed, 38 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c232292c5f5e..84a9431031d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Mar 13 19:55:58 UTC 2019
+# Thu Mar 14 15:17:59 UTC 2019
pkgbase = sdlmame-wout-toolkits
pkgdesc = A port of the popular Multiple Arcade Machine Emulator using SDL with OpenGL support. Without Qt toolkit
pkgver = 0.207
- pkgrel = 2
+ pkgrel = 3
url = http://mamedev.org
install = sdlmame-wout-toolkits.install
arch = x86_64
@@ -32,7 +32,7 @@ pkgbase = sdlmame-wout-toolkits
source = https://github.com/mamedev/mame/archive/mame0207.tar.gz
source = mame.sh
sha256sums = 69c29533d2128345c59fbf23fabc3af696322a77a6c1d7a7bd7f5a2ee57adafb
- sha256sums = b6c8eb86c38aa561b4638cb6e277a6f57adf0b8d8c4c4fa8df5070bda3125efe
+ sha256sums = 441ecf30fa03c13945947f56bb577b7e12c9a6cc287097fd969eb71be0f3ae85
pkgname = sdlmame-wout-toolkits
diff --git a/PKGBUILD b/PKGBUILD
index 4636749537c0..864c2365d7bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=sdlmame-wout-toolkits
pkgver=0.207
-pkgrel=2
+pkgrel=3
pkgdesc="A port of the popular Multiple Arcade Machine Emulator using SDL with OpenGL support. Without Qt toolkit"
url='http://mamedev.org'
license=('custom:MAME License')
@@ -36,7 +36,7 @@ source=("https://github.com/mamedev/mame/archive/mame${pkgver/./}.tar.gz"
'mame.sh'
)
sha256sums=('69c29533d2128345c59fbf23fabc3af696322a77a6c1d7a7bd7f5a2ee57adafb'
- 'b6c8eb86c38aa561b4638cb6e277a6f57adf0b8d8c4c4fa8df5070bda3125efe'
+ '441ecf30fa03c13945947f56bb577b7e12c9a6cc287097fd969eb71be0f3ae85'
)
install=sdlmame-wout-toolkits.install
diff --git a/mame.sh b/mame.sh
index bd73f0a9f2e8..d02b93a0b191 100644
--- a/mame.sh
+++ b/mame.sh
@@ -2,11 +2,13 @@
mamelib=/usr/lib/mame/
mame_first_run() {
- echo "Creating an ini file for MAME at ~/.mame/mame.ini"
+ echo "Creating an ini file for MAME at ~/.config/mame/mame.ini"
+ echo "Config and shared files is stored into"
+ echo " ~/.config/mame and ~/.local/share/mame"
echo "Modify this file for permanent changes to your MAME"
echo "options and paths before running MAME again."
- cd -- ~/.mame || exit
+ cd -- ~/.config/mame || exit
if [ -e mame.ini ]; then
mv mame.ini mameini.bak || exit
@@ -18,37 +20,43 @@ mame_first_run() {
# it is run in future.
mame \
- -rompath '$HOME/.mame/roms;roms' \
- -hashpath '$HOME/.mame/hash;hash' \
- -samplepath '$HOME/.mame/samples' \
- -artpath '$HOME/.mame/artwork;artwork' \
- -ctrlrpath '$HOME/.mame/ctrlr;ctrlr' \
- -inipath '$HOME/.mame/ini' \
- -fontpath '$HOME/.mame/fonts;fonts' \
- -cheatpath '$HOME/.mame/cheat' \
- -crosshairpath '$HOME/.mame/crosshair' \
- -pluginspath '$HOME/.mame/plugins;plugins' \
- -languagepath '$HOME/.mame/language;language' \
- -swpath '$HOME/.mame/software;software' \
- -cfg_directory '$HOME/.mame/cfg' \
- -nvram_directory '$HOME/.mame/nvram' \
- -input_directory '$HOME/.mame/inp' \
- -state_directory '$HOME/.mame/sta' \
- -snapshot_directory '$HOME/.mame/snap' \
- -diff_directory '$HOME/.mame/diff' \
- -comment_directory '$HOME/.mame/comments' \
+ -rompath '$HOME/.local/share/mame/roms;roms' \
+ -hashpath '$HOME/.local/share/mame/hash;hash' \
+ -samplepath '$HOME/.local/share/mame/samples' \
+ -artpath '$HOME/.local/share/mame/artwork;artwork' \
+ -ctrlrpath '$HOME/.local/share/mame/ctrlr;ctrlr' \
+ -inipath '$HOME/.config/mame/ini' \
+ -fontpath '$HOME/.local/share/mame/fonts;fonts' \
+ -cheatpath '$HOME/.local/share/mame/cheat' \
+ -crosshairpath '$HOME/.local/share/mame/crosshair' \
+ -pluginspath '$HOME/.local/share/mame/plugins;plugins' \
+ -languagepath '$HOME/.local/share/mame/language;language' \
+ -swpath '$HOME/.local/share/mame/software;software' \
+ -cfg_directory '$HOME/.config/mame/cfg' \
+ -nvram_directory '$HOME/.local/share/mame/nvram' \
+ -input_directory '$HOME/.local/share/mame/inp' \
+ -state_directory '$HOME/.local/share/mame/sta' \
+ -snapshot_directory '$HOME/.local/share/mame/snap' \
+ -diff_directory '$HOME/.local/share/mame/diff' \
+ -comment_directory '$HOME/.local/share/mame/comments' \
-video opengl \
-noreadconfig -showconfig > mame.ini
}
if [ "$1" = "--newini" ]; then
echo "Running MAME for the first time..."
- if ! [ -e ~/.mame ]; then
- mkdir -- ~/.mame
+ if ! [ -e ~/.config/mame ]; then
+ mkdir -- ~/.config/mame
fi
+ if ! [ -e ~/.local/share/mame ]; then
+ mkdir -- ~/.local/share/mame
+ fi
+
(
- cd -- ~/.mame || exit
- mkdir -p roms hash samples artwork ctrlr ini fonts cheat crosshair plugins language software
+ cd -- ~/.config/mame || exit
+ mkdir -p ini
+ cd -- ~/.local/share/mame || exit
+ mkdir -p roms hash samples artwork ctrlr fonts cheat crosshair plugins language software
mame_first_run
) || exit
fi