summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2021-12-30 14:34:40 +0100
committerXiretza2021-12-30 14:34:40 +0100
commitc2c0ff5bbdfa906e96319566e939637549adff28 (patch)
tree51211ad732288d90cb099ff5f9201a0f3a89e2a6
parent18d2e4f17af778115b3c749bf25ff680221e3b37 (diff)
downloadaur-c2c0ff5bbdfa906e96319566e939637549adff28.tar.gz
Remove upstreamed patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--pr-1092.patch78
3 files changed, 5 insertions, 87 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6aa5e05ebd88..ed902cbe0065 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sdrangel-git
pkgdesc = Qt5/OpenGL SDR and signal analyzer frontend.
- pkgver = 6.17.6.r7.5c742a873
+ pkgver = 6.17.6.r9.60c0e3117
pkgrel = 1
url = https://github.com/f4exb/sdrangel
arch = x86_64
@@ -71,11 +71,9 @@ pkgbase = sdrangel-git
optdepends = airspyhf: Airspy HF+ support
optdepends = libxtrx: XTRX SDR support
optdepends = libuhd: USRP support
- provides = sdrangel=6.17.6.r7.5c742a873
+ provides = sdrangel=6.17.6.r9.60c0e3117
conflicts = sdrangel
source = git+https://github.com/f4exb/sdrangel
- source = pr-1092.patch
sha512sums = SKIP
- sha512sums = 4b749458458d6b9b89f50c7fdc250fdab1320d44693a7c9c168c46277d3ec50da58043d1625d6cfefa32ba9280c0cfe9b927bc016f3b7deedce97e88f2eeca18
pkgname = sdrangel-git
diff --git a/PKGBUILD b/PKGBUILD
index e889ad556c56..acab77af6e3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=sdrangel
pkgname=$_pkgname-git
-pkgver=6.17.6.r7.5c742a873
+pkgver=6.17.6.r9.60c0e3117
pkgrel=1
pkgdesc='Qt5/OpenGL SDR and signal analyzer frontend.'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -41,9 +41,8 @@ optdepends=('ffmpeg: DATV demodulator'
)
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
-source=("git+$url" "pr-1092.patch")
-sha512sums=('SKIP'
- '4b749458458d6b9b89f50c7fdc250fdab1320d44693a7c9c168c46277d3ec50da58043d1625d6cfefa32ba9280c0cfe9b927bc016f3b7deedce97e88f2eeca18')
+source=("git+$url")
+sha512sums=('SKIP')
pkgver() {
cd "$_pkgname"
@@ -53,7 +52,6 @@ pkgver() {
prepare() {
cd "$_pkgname"
- patch -p1 < "$srcdir/pr-1092.patch"
}
build() {
diff --git a/pr-1092.patch b/pr-1092.patch
deleted file mode 100644
index 568fd8e3a3f9..000000000000
--- a/pr-1092.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From cc3f4ab2f8eeddeee6ce9740b940c8c07e4031bf Mon Sep 17 00:00:00 2001
-From: Jon Beniston <jon@beniston.com>
-Date: Tue, 28 Dec 2021 11:31:15 +0000
-Subject: [PATCH] Fix for #1087. Support compilation with Boost >= 1.77
-
----
- plugins/channelrx/noisefigure/noisefigure.cpp | 9 ++++++++-
- .../channelrx/noisefigure/noisefigureenrdialog.cpp | 11 ++++++++++-
- 2 files changed, 18 insertions(+), 2 deletions(-)
-
-diff --git a/plugins/channelrx/noisefigure/noisefigure.cpp b/plugins/channelrx/noisefigure/noisefigure.cpp
-index a6a08d413..646fbf065 100644
---- a/plugins/channelrx/noisefigure/noisefigure.cpp
-+++ b/plugins/channelrx/noisefigure/noisefigure.cpp
-@@ -16,6 +16,7 @@
- // along with this program. If not, see <http://www.gnu.org/licenses/>. //
- ///////////////////////////////////////////////////////////////////////////////////
-
-+#include <boost/version.hpp>
- #include <boost/math/interpolators/barycentric_rational.hpp>
-
- #include "noisefigure.h"
-@@ -41,6 +42,12 @@
- #include "channel/channelwebapiutils.h"
- #include "maincore.h"
-
-+#if BOOST_VERSION < 107700
-+using namespace boost::math;
-+#else
-+using namespace boost::math::interpolators;
-+#endif
-+
- MESSAGE_CLASS_DEFINITION(NoiseFigure::MsgConfigureNoiseFigure, Message)
- MESSAGE_CLASS_DEFINITION(NoiseFigure::MsgPowerMeasurement, Message)
- MESSAGE_CLASS_DEFINITION(NoiseFigure::MsgNFMeasurement, Message)
-@@ -180,7 +187,7 @@ double NoiseFigure::calcENR(double frequency)
- else
- {
- int order = size - 1;
-- boost::math::barycentric_rational<double> interpolant(std::move(x), std::move(y), order);
-+ barycentric_rational<double> interpolant(std::move(x), std::move(y), order);
- enr = interpolant(frequency);
- }
- }
-diff --git a/plugins/channelrx/noisefigure/noisefigureenrdialog.cpp b/plugins/channelrx/noisefigure/noisefigureenrdialog.cpp
-index 1200fe989..e51afe232 100644
---- a/plugins/channelrx/noisefigure/noisefigureenrdialog.cpp
-+++ b/plugins/channelrx/noisefigure/noisefigureenrdialog.cpp
-@@ -17,11 +17,20 @@
-
- #include <QDebug>
-
-+#include <array>
-+
-+#include <boost/version.hpp>
- #include <boost/math/interpolators/barycentric_rational.hpp>
-
- #include "noisefigureenrdialog.h"
- #include "util/interpolation.h"
-
-+#if BOOST_VERSION < 107700
-+using namespace boost::math;
-+#else
-+using namespace boost::math::interpolators;
-+#endif
-+
- NoiseFigureENRDialog::NoiseFigureENRDialog(NoiseFigureSettings *settings, QWidget* parent) :
- QDialog(parent),
- m_settings(settings),
-@@ -153,7 +162,7 @@ void NoiseFigureENRDialog::plotChart()
- y[i] = points[i][1];
- }
- int order = size - 1;
-- boost::math::barycentric_rational<double> interpolant(std::move(x), std::move(y), order);
-+ barycentric_rational<double> interpolant(std::move(x), std::move(y), order);
-
- x.resize(size);
- y.resize(size);