summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2021-04-23 22:28:12 +0200
committerXiretza2021-04-23 22:28:12 +0200
commit8b4b55dd42e977a982cfa59d261a1c31b36fb144 (patch)
treec9db7b10c1d60d7315e6dc3868b79f35f45e0763
parentd65eb1927fc9049a6ea284da0e8587bbaf863937 (diff)
downloadaur-8b4b55dd42e977a982cfa59d261a1c31b36fb144.tar.gz
Fix inhibition of processor-specific optimizations
The build system tries to be smart and add -march=native by default, but this is not what we want. Setting ARCH_OPT to an empty string prevents an additional -march= from being generated, while still allowing for detection of CPU features available for the architecture specified by makepkg.conf.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 333b3813fa00..6cf35f6825ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sdrangel-git
pkgdesc = Qt5/OpenGL SDR and signal analyzer frontend.
- pkgver = 6.6.0.r6.ef1419d66
+ pkgver = 6.10.1.r15.ec8cdc63f
pkgrel = 1
url = https://github.com/f4exb/sdrangel
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 3401c18b28ea..81614282284e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=sdrangel-git
_pkgname=${pkgname%-git}
-pkgver=6.6.0.r6.ef1419d66
+pkgver=6.10.1.r15.ec8cdc63f
pkgrel=1
pkgdesc='Qt5/OpenGL SDR and signal analyzer frontend.'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -46,7 +46,7 @@ build() {
# https://bugs.gentoo.org/704322
export CXXFLAGS="$CXXFLAGS -fpermissive"
cmake .. \
- -DENABLE_GENERIC=1 \
+ -DARCH_OPT="" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIBDSDCC_INCLUDE_DIR=/usr/include/dsdcc \