summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Salcedo2021-10-13 10:08:40 -0500
committerBrian Salcedo2021-10-13 10:08:40 -0500
commitf1fceffb90db2940a9f12acff7bd9ffa9105e52b (patch)
tree6e3c0dc4dc875db68491078838f923cd6afbdb5f
downloadaur-f1fceffb90db2940a9f12acff7bd9ffa9105e52b.tar.gz
initial commit
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD28
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0514fa26e2ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = sdrpp
+ pkgdesc = The Bloat-free SDR Receiver - Release Version
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/AlexandreRouma/SDRPlusPlus
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = gcc
+ makedepends = make
+ makedepends = cmake
+ makedepends = soapysdr
+ makedepends = libiio
+ makedepends = libad9361
+ makedepends = rtl-sdr
+ makedepends = airspy
+ makedepends = airspyhf-git
+ makedepends = hackrf
+ makedepends = libsdrplay
+ depends = fftw
+ depends = glfw
+ depends = glew
+ depends = libvolk
+ depends = rtaudio
+ optdepends = soapysdr
+ optdepends = libiio
+ optdepends = libad9361
+ optdepends = rtl-sdr
+ optdepends = airspy
+ optdepends = airspyhf-git
+ optdepends = hackrf
+ optdepends = libsdrplay
+ conflicts = sdrpp-git
+ source = https://github.com/AlexandreRouma/SDRPlusPlus/archive/refs/tags/1.0.3.tar.gz
+ md5sums = 0fc1b8baf5386fef5601f2c996e35503
+
+pkgname = sdrpp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58f462b2d144
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Brian Salcedo <brian@salcedo.tech>
+# Contributor: Alexandre Rouma <whatsthetgeek@gmail.com>
+pkgname=sdrpp
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="The Bloat-free SDR Receiver - Release Version"
+arch=('any')
+url="https://github.com/AlexandreRouma/SDRPlusPlus"
+license=('GPL')
+conflicts=('sdrpp-git')
+depends=("fftw" "glfw" "glew" "libvolk" "rtaudio")
+makedepends=("git" "gcc" "make" "cmake" "soapysdr" "libiio" "libad9361" "rtl-sdr" "airspy" "airspyhf-git" "hackrf" "libsdrplay")
+optdepends=("soapysdr" "libiio" "libad9361" "rtl-sdr" "airspy" "airspyhf-git" "hackrf" "libsdrplay")
+source=('https://github.com/AlexandreRouma/SDRPlusPlus/archive/refs/tags/1.0.3.tar.gz')
+md5sums=('0fc1b8baf5386fef5601f2c996e35503')
+
+build() {
+ cd "SDRPlusPlus-${pkgver}"
+ mkdir build
+ cd build
+ cmake .. -DOPT_BUILD_SDRPLAY_SOURCE=ON
+ make $MAKEOPTS
+}
+
+package() {
+ cd "SDRPlusPlus-${pkgver}/build"
+ make DESTDIR="$pkgdir/" install
+}