summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRiccardo Sacchetto2022-03-26 19:41:17 +0100
committerRiccardo Sacchetto2022-03-26 19:41:17 +0100
commit1faa332ddee53125e61595681f74dfbdcf22cd9c (patch)
tree08f30b7ea50e4d763d881ad6a6e9c1246b0be266
parent7f2977ddf58dc4f4e6f3c6ff2bef406bcd2e77d9 (diff)
downloadaur-1faa332ddee53125e61595681f74dfbdcf22cd9c.tar.gz
Release version 0.7.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71dcf81d45f2..c64630ceb252 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = sea-orm-cli
pkgdesc = CLI for the Sea-Orm crate
- pkgver = 0.6.0
+ pkgver = 0.7.0
pkgrel = 1
- url = https://www.sea-ql.org/seaorm/
+ url = https://www.sea-ql.org/SeaORM/
arch = x86_64
license = MIT
license = Apache
@@ -10,7 +10,7 @@ pkgbase = sea-orm-cli
depends = sqlite
depends = postgresql-libs
depends = libmariadbclient
- source = https://github.com/SeaQL/sea-orm/archive/refs/tags/0.6.0.tar.gz
- sha512sums = ed37796d3a1ca3bb4c6d214aa939e8e5747071ff431cc2c84f38d70259281ca5c073f5671b051a7c3a2199bf4bb49b31c435e59f2cf4bd31a687e3bfa2a5d0a5
+ source = https://github.com/SeaQL/sea-orm/archive/refs/tags/0.7.0.tar.gz
+ sha512sums = 835fd2fc031ec5f6690a8f84e913d813880fb8bd214a92269ff55c9cff428472f215a1758cc726863fd3655e3ffe2d468cf348391ab0138af710b49d735ac0e4
pkgname = sea-orm-cli
diff --git a/PKGBUILD b/PKGBUILD
index 38283bed8ec7..45aa07cbcaf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
# Maintainer: Riccardo Sacchetto <rsacchetto@nexxontech.it>
pkgname=sea-orm-cli
-pkgver=0.6.0
+pkgver=0.7.0
pkgrel=1
pkgdesc="CLI for the Sea-Orm crate"
arch=('x86_64')
-url="https://www.sea-ql.org/seaorm/"
+url="https://www.sea-ql.org/SeaORM/"
license=('MIT' 'Apache')
depends=('sqlite' 'postgresql-libs' 'libmariadbclient')
makedepends=('cargo')
source=("https://github.com/SeaQL/sea-orm/archive/refs/tags/${pkgver}.tar.gz")
-sha512sums=('ed37796d3a1ca3bb4c6d214aa939e8e5747071ff431cc2c84f38d70259281ca5c073f5671b051a7c3a2199bf4bb49b31c435e59f2cf4bd31a687e3bfa2a5d0a5')
+sha512sums=('835fd2fc031ec5f6690a8f84e913d813880fb8bd214a92269ff55c9cff428472f215a1758cc726863fd3655e3ffe2d468cf348391ab0138af710b49d735ac0e4')
prepare() {
# Enter the sea-orm-cli source folder downloaded from GitHub
cd "sea-orm-${pkgver}/sea-orm-cli"
- # A specific sea-orm-cli release requires the matching sea-schema version: update Cargo.toml to avoid errors
- sed -i 's/git = "https:\/\/github.com\/SeaQL\/sea-schema.git"/git = "https:\/\/github.com\/SeaQL\/sea-schema.git", tag = "0.5.0"/' Cargo.toml
# Fetch the dependencies
cargo fetch --target "$CARCH-unknown-linux-gnu"
}