summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2017-08-21 17:08:15 +0100
committerGrey Christoforo2017-08-21 17:08:15 +0100
commitf512fb9cd759197a390e03f40d5bbbb17695cfb9 (patch)
treebbcd7259f5f8211ac1a070aa17a045f42e5625a3
downloadaur-f512fb9cd759197a390e03f40d5bbbb17695cfb9.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD22
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9b6d2b0c18c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Mon Aug 21 16:07:21 UTC 2017
+pkgbase = seabreeze
+ pkgdesc = SeaBreeze is a device driver library that provides an interface to select Ocean Optics spectrometers
+ pkgver = 3.0.11
+ pkgrel = 1
+ url = https://oceanoptics.com/product/seabreeze/
+ arch = any
+ license = MIT
+ depends = libusb
+ source = https://downloads.sourceforge.net/project/seabreeze/SeaBreeze/source/seabreeze-3.0.11.zip
+ md5sums = 163aa19239838bf87462acc6eef7838c
+
+pkgname = seabreeze
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..279dac4e61d6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar.xz
+*.tgz
+*.zip
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c3042e7f968
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=seabreeze
+pkgver=3.0.11
+pkgrel=1
+pkgdesc="SeaBreeze is a device driver library that provides an interface to select Ocean Optics spectrometers"
+arch=('any')
+url="https://oceanoptics.com/product/seabreeze/"
+license=('MIT')
+source=("https://downloads.sourceforge.net/project/seabreeze/SeaBreeze/source/seabreeze-${pkgver}.zip")
+md5sums=('163aa19239838bf87462acc6eef7838c')
+depends=('libusb')
+
+build() {
+ cd "$srcdir/$pkgname-${pkgver}"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+}