summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmanuele 'Lele' Calo2021-08-31 15:05:19 +0200
committerEmanuele 'Lele' Calo2021-08-31 15:05:19 +0200
commit88015f8c5e925b9a5f73d545af80e83ad1e37e18 (patch)
tree94b18eea23c9b050d222fcdb4f933db6f7b26679
parent8124a18b8d75cd4a3590fdb174c9b9bc03528b19 (diff)
downloadaur-88015f8c5e925b9a5f73d545af80e83ad1e37e18.tar.gz
Updated to version 2.0.15
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
-rwxr-xr-xseadrive3
3 files changed, 9 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1adce8c3cc05..32d553ce9326 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = seadrive-daemon
pkgdesc = Daemon part of seadrive
- pkgver = 2.0.10
+ pkgver = 2.0.15
pkgrel = 1
- url = https://download.seafile.com/published/seafile-user-manual/drive_client/drive_client_for_linux.md
+ url = https://www.seafile.com/en/download/
arch = x86_64
license = Apache
depends = libsearpc
@@ -10,10 +10,7 @@ pkgbase = seadrive-daemon
depends = libevent-compat
depends = openssl-1.0
depends = fuse2
- source = seadrive
- source = http://linux-clients.seafile.com/seadrive-deb/focal/pool/main/s/seadrive-daemon/seadrive-daemon_2.0.10_amd64.deb
- sha256sums = 25770d58f6e262a29e54a065ccf5e2d138ec5ec2aecaafa12fe2f6fe4ca256fb
- sha256sums = 21136593bbf5074b708fe296ad30d27a8363b2c8d3ff3fdf91c77c5f4013bef7
+ source = http://linux-clients.seafile.com/seadrive-deb/focal/pool/main/s/seadrive-daemon/seadrive-daemon_2.0.15_amd64.deb
+ sha256sums = ae1bcb14dd2e85cdaa32d14140e87e81ec3915cb356b1a32e89e97fe282e0ba3
pkgname = seadrive-daemon
-
diff --git a/PKGBUILD b/PKGBUILD
index c279bbf738ad..af8764ff9555 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,16 @@
# Co-Maintainer: eldios
pkgname=seadrive-daemon
-pkgver=2.0.10
+pkgver=2.0.15
pkgrel=1
pkgdesc="Daemon part of seadrive"
arch=('x86_64')
-url="https://download.seafile.com/published/seafile-user-manual/drive_client/drive_client_for_linux.md"
+url="https://www.seafile.com/en/download/"
license=('Apache')
depends=('libsearpc' 'libcurl-compat' 'libevent-compat'
'openssl-1.0' 'fuse2')
-source=('seadrive'
- "http://linux-clients.seafile.com/seadrive-deb/focal/pool/main/s/${pkgname}/${pkgname}_${pkgver}_amd64.deb")
-sha256sums=('25770d58f6e262a29e54a065ccf5e2d138ec5ec2aecaafa12fe2f6fe4ca256fb'
- '21136593bbf5074b708fe296ad30d27a8363b2c8d3ff3fdf91c77c5f4013bef7')
+source=("http://linux-clients.seafile.com/seadrive-deb/focal/pool/main/s/${pkgname}/${pkgname}_${pkgver}_amd64.deb")
+sha256sums=('ae1bcb14dd2e85cdaa32d14140e87e81ec3915cb356b1a32e89e97fe282e0ba3')
prepare() {
cd "${srcdir}"
@@ -24,6 +22,5 @@ prepare() {
package () {
cd "${srcdir}"
- install -Dm 755 "${srcdir}/seadrive" "${pkgdir}/usr/bin/seadrive"
- install -Dm 755 "${srcdir}/usr/bin/seadrive" "${pkgdir}/usr/share/seadrive/seadrive"
+ install -Dm 755 "${srcdir}/usr/bin/seadrive" "${pkgdir}/usr/bin/seadrive"
}
diff --git a/seadrive b/seadrive
deleted file mode 100755
index 333244618996..000000000000
--- a/seadrive
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-export LD_PRELOAD="libcurl.so.4.5.0"
-/usr/share/seadrive/seadrive "$@"