summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpiater2022-12-20 17:17:42 +0100
committerpiater2022-12-20 17:17:42 +0100
commit9edbd56261c13c8ea0a71f55559dcebc5b1efc3f (patch)
tree92c87e5d7f4b3df98bff19fcd54009bb6137b321
parent7513b025ef6386f087029b1ec210af6533d3784d (diff)
downloadaur-9edbd56261c13c8ea0a71f55559dcebc5b1efc3f.tar.gz
New maintainer; build from source instead of extracting from .deb
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 30 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 916e0db01852..789a6fed7629 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = seadrive-daemon
- pkgdesc = Daemon part of seadrive
+ pkgdesc = SeaDrive daemon with FUSE interface
pkgver = 2.0.22
- pkgrel = 1
- url = https://www.seafile.com/en/download/ + https://linux-clients.seafile.com/seadrive-deb/focal/pool/main/s/seadrive-daemon/
+ pkgrel = 2
+ url = https://github.com/haiwen/seadrive-fuse
arch = x86_64
- license = Apache
+ license = GPL3
+ makedepends = git
depends = libsearpc
- depends = libcurl-compat
- depends = libevent-compat
- depends = openssl-1.0
+ depends = sqlite
+ depends = curl
depends = fuse2
- source = http://linux-clients.seafile.com/seadrive-deb/focal/pool/main/s/seadrive-daemon/seadrive-daemon_2.0.22_amd64.deb
- sha256sums = 8990b833647cc3c3ba2d58124f2cd8e27ad5a03cc768f4396a860700da7ac6f3
+ depends = libevent
+ depends = openssl
+ source = git+https://github.com/haiwen/seadrive-fuse.git#tag=07a788a395e4669156bca294475692fb56b24947
+ sha256sums = SKIP
pkgname = seadrive-daemon
diff --git a/PKGBUILD b/PKGBUILD
index 96c47e5f9024..04783256e60c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,28 @@
-# Maintainer: c0gnitivefl0w
-# Co-Maintainer: eldios
+# Maintainer: Justus Piater <Justus-dev at Piater dot name>
+_reponame=seadrive-fuse
pkgname=seadrive-daemon
pkgver=2.0.22
-pkgrel=1
-pkgdesc="Daemon part of seadrive"
+pkgrel=2
+pkgdesc="SeaDrive daemon with FUSE interface"
arch=('x86_64')
-url="https://www.seafile.com/en/download/ + https://linux-clients.seafile.com/seadrive-deb/focal/pool/main/s/seadrive-daemon/"
-license=('Apache')
-depends=('libsearpc' 'libcurl-compat' 'libevent-compat'
- 'openssl-1.0' 'fuse2')
-source=("http://linux-clients.seafile.com/seadrive-deb/focal/pool/main/s/${pkgname}/${pkgname}_${pkgver}_amd64.deb")
-sha256sums=('8990b833647cc3c3ba2d58124f2cd8e27ad5a03cc768f4396a860700da7ac6f3')
+url="https://github.com/haiwen/seadrive-fuse"
+license=('GPL3')
+depends=('libsearpc' 'sqlite' 'curl' 'fuse2' 'libevent' 'openssl')
+makedepends=('git')
+_tag=07a788a395e4669156bca294475692fb56b24947 # git rev-parse v${pkgver}
+source=("git+https://github.com/haiwen/$_reponame.git#tag=$_tag")
+sha256sums=('SKIP')
-prepare() {
- cd "${srcdir}"
-
- tar -xJf data.tar.xz
+build() {
+ cd "$srcdir/$_reponame"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
}
package () {
- cd "${srcdir}"
-
- install -Dm 755 "${srcdir}/usr/bin/seadrive" "${pkgdir}/usr/bin/seadrive"
+ install -Dm 755 \
+ "${srcdir}/$_reponame/src/seadrive" \
+ "${pkgdir}/usr/bin/seadrive"
}