summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2017-04-24 23:05:22 +0200
committereolianoe2017-04-24 23:05:22 +0200
commit2e534d7e21ff042a115d70c6c0c97378c8a2ae9b (patch)
treee1d5f46308f58fcbc7f1e8f22bbacb0e4eeed792
parent7678b94e66056f56fabe7a94e579cd0ead64d7ee (diff)
downloadaur-2e534d7e21ff042a115d70c6c0c97378c8a2ae9b.tar.gz
openssl fix
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--openssl-1.0.patch20
3 files changed, 32 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35d9e510016f..5eedc6e6e7e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Mar 17 19:36:20 UTC 2017
+# Mon Apr 24 21:05:16 UTC 2017
pkgbase = seafile
pkgdesc = Seafile is an online file storage and collaboration tool
pkgver = 6.0.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/haiwen/seafile
arch = i686
arch = x86_64
@@ -20,8 +20,10 @@ pkgbase = seafile
provides = seafile-client-cli
source = seafile-6.0.4.tar.gz::https://github.com/haiwen/seafile/archive/v6.0.4.tar.gz
source = libseafile.in.patch
+ source = openssl-1.0.patch
sha256sums = b3919bff1e0f974483df129e500868332e752dec6380556839e006bf9d5b425e
sha256sums = a2d7f7cf0c59aba97650af62b3cefd0ceb71a1007c34d9369a88e5769c7f6076
+ sha256sums = de1b28f5ed08dfc5722f4dfda85f4ecb4a4fb707089adb612fea51d7f51e7f1f
pkgname = seafile
diff --git a/PKGBUILD b/PKGBUILD
index ceabf41766e1..7e5caa20df9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=seafile
pkgver=6.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="Seafile is an online file storage and collaboration tool"
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/haiwen/${pkgname}"
@@ -12,15 +12,18 @@ license=('GPL2')
depends=("ccnet" "fuse" "python2" "sqlite")
makedepends=("vala" "intltool")
source=("seafile-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
- "libseafile.in.patch")
+ "libseafile.in.patch"
+ "openssl-1.0.patch")
sha256sums=('b3919bff1e0f974483df129e500868332e752dec6380556839e006bf9d5b425e'
- 'a2d7f7cf0c59aba97650af62b3cefd0ceb71a1007c34d9369a88e5769c7f6076')
+ 'a2d7f7cf0c59aba97650af62b3cefd0ceb71a1007c34d9369a88e5769c7f6076'
+ 'de1b28f5ed08dfc5722f4dfda85f4ecb4a4fb707089adb612fea51d7f51e7f1f')
provides=('seafile-client-cli')
prepare () {
cd "${srcdir}/seafile-${pkgver}"
patch -p1 -i "${srcdir}/libseafile.in.patch"
+ patch -p0 -i "${srcdir}"/openssl-1.0.patch
# Fix all script's python 2 requirement
grep -s -l -r '#!/usr/bin/env python' "${srcdir}/seafile-${pkgver}" \
@@ -30,6 +33,8 @@ prepare () {
build() {
cd "$srcdir/seafile-${pkgver}"
+ export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
+
./autogen.sh
./configure \
diff --git a/openssl-1.0.patch b/openssl-1.0.patch
new file mode 100644
index 000000000000..b51253c87aa8
--- /dev/null
+++ b/openssl-1.0.patch
@@ -0,0 +1,20 @@
+--- lib/Makefile.am.orig 2017-02-17 03:39:51.000000000 +0100
++++ lib/Makefile.am 2017-04-04 23:49:52.849386841 +0200
+@@ -7,6 +7,7 @@
+ -I$(top_srcdir)/common \
+ @CCNET_CFLAGS@ \
+ @SEARPC_CFLAGS@ \
++ @SSL_CFLAGS@ \
+ @MSVC_CFLAGS@ \
+ -Wall
+
+--- daemon/Makefile.am.orig 2017-04-24 22:57:21.895319096 +0200
++++ daemon/Makefile.am 2017-04-24 22:57:08.558729290 +0200
+@@ -8,6 +8,7 @@
+ -I$(top_srcdir)/common \
+ @CCNET_CFLAGS@ \
+ @SEARPC_CFLAGS@ \
++ @SSL_CFLAGS@ \
+ @GLIB2_CFLAGS@ \
+ @MSVC_CFLAGS@ \
+ @CURL_CFLAGS@ \