summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdvinas Valatka2016-04-10 06:20:57 +0300
committerEdvinas Valatka2016-04-10 06:20:57 +0300
commit94a794f3a2b7d1b080464f4fce09c099e5c1ddc5 (patch)
treef43c62bfdeaa73b9a24871f7f9e389f24eb2a2b6
parent994c958001cae8794f39a8ddb74f9003932694d9 (diff)
downloadaur-94a794f3a2b7d1b080464f4fce09c099e5c1ddc5.tar.gz
Version 5.1.1-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD9
-rw-r--r--seafile-admin_virtualenv.patch15
-rwxr-xr-xseafile-server.install16
4 files changed, 29 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29ec302fc7af..efa63fda69c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Mar 1 15:38:55 UTC 2016
+# Sun Apr 10 03:12:54 UTC 2016
pkgbase = seafile-server
pkgdesc = Seafile is an online file storage and collaboration tool
- pkgver = 5.0.5
- pkgrel = 2
+ pkgver = 5.1.1
+ pkgrel = 1
url = https://github.com/haiwen/seafile/
arch = i686
arch = x86_64
@@ -15,17 +15,17 @@ pkgbase = seafile-server
makedepends = python2
makedepends = sqlite
makedepends = fuse
- makedepends = ccnet>=5.0.5
+ makedepends = ccnet>=5.1.1
makedepends = libevhtp-seafile=1.2.9
- source = seafile-server-5.0.5.tar.gz::https://github.com/haiwen/seafile/archive/v5.0.5-server.tar.gz
+ source = seafile-server-5.1.1.tar.gz::https://github.com/haiwen/seafile/archive/v5.1.1-server.tar.gz
source = seafile-admin_virtualenv.patch
source = seafile-server@.service
source = seahub-preupgrade
source = create-default-conf-dir.patch
source = 0001-Revert-server-put-pids-folder-out-of-seafile-data.patch
source = libseafile.in.patch
- sha256sums = 43fd3c0f1a4ae20a2e41089732142af621c21d5ad6d6eb8a977a520d77d27bfa
- sha256sums = 876e67526fabf83bfeb5ff50f05b2f4725f3d9bf784025707b67022a1a311f20
+ sha256sums = 60b5bf6cfc3f65359eada827733eb4c4720535db3c6dc1a37be1c3470f7c7030
+ sha256sums = 52fb29858f6424052cf01630ad72b5687a4fb259f23f9efc97f08be04a883218
sha256sums = ae1ed38f94304d27e4ef1ca66e15d544f99681c1e743c510c54d4a112f050421
sha256sums = 2a1e079cbea3543f356e6e9571f3d7d2a4b0ab75131ee417115d738ea191c4fb
sha256sums = 6bd632f8741b039bad961af3d6850b651e25b7e7a3018d6e2789f350ff93bb78
@@ -48,7 +48,8 @@ pkgname = seafile-server
depends = python2-simplejson
depends = libevhtp-seafile
depends = git
- conflicts = seafile-shared<5.0.5
+ optdepends = libmysqlclient: mysql server support
+ conflicts = seafile-shared<5.1.1
options = !libtool
options = !emptydirs
@@ -56,11 +57,11 @@ pkgname = seafile-client-cli
pkgdesc = Seafile cli client
depends = seafile-shared
depends = libevent
- conflicts = seafile-shared<5.0.5
+ conflicts = seafile-shared<5.1.1
pkgname = seafile-shared
pkgdesc = Shared components of Seafile (seafile-daemon, libseafile, python bindings, manuals)
depends = ccnet
depends = fuse
- conflicts = ccnet<5.0.5
+ conflicts = ccnet<5.1.1
diff --git a/PKGBUILD b/PKGBUILD
index bad4685f350a..cc70f003a05e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Aaron Lindsay <aaron@aclindsay.com>
pkgname=('seafile-server' 'seafile-client-cli' 'seafile-shared')
-pkgver=5.0.5
-pkgrel=2
+pkgver=5.1.1
+pkgrel=1
pkgdesc="Seafile is an online file storage and collaboration tool"
arch=('i686' 'x86_64' 'armv7h' 'armv6h')
url="https://github.com/haiwen/seafile/"
@@ -18,8 +18,8 @@ source=("seafile-server-${pkgver}.tar.gz::https://github.com/haiwen/seafile/arch
"create-default-conf-dir.patch"
"0001-Revert-server-put-pids-folder-out-of-seafile-data.patch"
"libseafile.in.patch")
-sha256sums=('43fd3c0f1a4ae20a2e41089732142af621c21d5ad6d6eb8a977a520d77d27bfa'
- '876e67526fabf83bfeb5ff50f05b2f4725f3d9bf784025707b67022a1a311f20'
+sha256sums=('60b5bf6cfc3f65359eada827733eb4c4720535db3c6dc1a37be1c3470f7c7030'
+ '52fb29858f6424052cf01630ad72b5687a4fb259f23f9efc97f08be04a883218'
'ae1ed38f94304d27e4ef1ca66e15d544f99681c1e743c510c54d4a112f050421'
'2a1e079cbea3543f356e6e9571f3d7d2a4b0ab75131ee417115d738ea191c4fb'
'6bd632f8741b039bad961af3d6850b651e25b7e7a3018d6e2789f350ff93bb78'
@@ -92,6 +92,7 @@ package_seafile-server() {
"python2-mako" "python2-dateutil" "python2-webpy" "python2-pip"
"python2-virtualenv" "python2-flup" "python2-six" "python2-chardet"
"python2-simplejson" "libevhtp-seafile" "git")
+ optdepends=('libmysqlclient: mysql server support' )
conflicts=("seafile-shared<${pkgver}")
options=('!libtool' '!emptydirs')
install=seafile-server.install
diff --git a/seafile-admin_virtualenv.patch b/seafile-admin_virtualenv.patch
index 98a85c341ab4..6a26e2710675 100644
--- a/seafile-admin_virtualenv.patch
+++ b/seafile-admin_virtualenv.patch
@@ -1,22 +1,17 @@
-diff --git a/tools/seafile-admin b/tools/seafile-admin
-index 102cf9f..ce77c35 100755
--- a/tools/seafile-admin
+++ b/tools/seafile-admin
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/lib/seafile/seafileenv/bin/python2
# coding: UTF-8
-
'''This is the helper script to setup/manage your seafile server
-@@ -604,7 +604,8 @@ def start_controller():
+ '''
+@@ -683,7 +683,7 @@
def start_seahub_gunicorn():
argv = [
-- 'gunicorn_django',
-+ PYTHON,
-+ '/usr/lib/seafile/seafileenv/bin/gunicorn_django',
+- 'gunicorn',
++ '/usr/lib/seafile/seafileenv/bin/gunicorn',
+ 'seahub.wsgi:application',
'-c',
conf[CONF_SEAHUB_CONF],
- '-b',
- '0.0.0.0:%s' % conf[CONF_SEAHUB_PORT],
- ]
diff --git a/seafile-server.install b/seafile-server.install
index d1e2082ee1f7..394708cb4209 100755
--- a/seafile-server.install
+++ b/seafile-server.install
@@ -3,17 +3,17 @@ pre_install() {
virtualenv2 --relocatable /usr/lib/seafile/seafileenv
source /usr/lib/seafile/seafileenv/bin/activate
- pip2 install gunicorn
- pip2 install "Django>=1.5.8,<1.6"
- pip2 install django-pipeline
- pip2 install http://effbot.org/media/downloads/PIL-1.1.7.tar.gz
- pip2 install "https://github.com/djblets/djblets/archive/release-0.6.14.zip#egg=Djblets"
- pip2 install "Pillow>=2.6.1,<3.0.0"
- pip2 install "django-compressor==1.4"
+ pip2 install "Django==1.8.10"
pip2 install "django-statici18n==1.1.2"
+ pip2 install "django-compressor==1.4"
pip2 install "git+git://github.com/haiwen/django-constance.git@bde7f7cdfd0ed1631a6817fd4cd76f37bf54fe35#egg=django-constance[database]"
pip2 install "openpyxl==2.3.0"
-
+ pip2 install "pytz==2015.7"
+ pip2 install "djangorestframework==3.3.1"
+ pip2 install "django-post-office==2.0.3"
+ pip2 install "Pillow>=2.6.1,<3.0.0"
+ pip2 install "python-memcached==1.57"
+ pip2 install gunicorn
deactivate
}