summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdvinas Valatka2016-01-31 20:05:44 +0200
committerEdvinas Valatka2016-01-31 20:05:44 +0200
commitf60499e3f1dab9254136c80ca3db613615f2185f (patch)
treea49a80705418ad74fe19f6b18c22bd3bd9f80e6f
parenteb22dd0b4f7d4304e444cba8b3627ff87ee8d387 (diff)
parenta4d1a6d7da46633640077a981378273734b36e72 (diff)
downloadaur-f60499e3f1dab9254136c80ca3db613615f2185f.tar.gz
Merge branch 'release-5.0.5-1'
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD12
-rwxr-xr-xseafile-server.install24
3 files changed, 28 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e94218cced2..d387a214520e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Jan 14 01:31:11 UTC 2016
+# Sun Jan 31 15:08:44 UTC 2016
pkgbase = seafile-server
pkgdesc = Seafile is an online file storage and collaboration tool
- pkgver = 5.0.4
- pkgrel = 4
+ pkgver = 5.0.5
+ pkgrel = 1
url = https://github.com/haiwen/seafile/
arch = i686
arch = x86_64
@@ -15,16 +15,16 @@ pkgbase = seafile-server
makedepends = python2
makedepends = sqlite
makedepends = fuse
- makedepends = ccnet>=5.0.4
+ makedepends = ccnet>=5.0.5
makedepends = libevhtp-seafile=1.2.9
- source = seafile-server-5.0.4.tar.gz::https://github.com/haiwen/seafile/archive/v5.0.4-server.tar.gz
+ source = seafile-server-5.0.5.tar.gz::https://github.com/haiwen/seafile/archive/v5.0.5-server.tar.gz
source = seafile-admin_virtualenv.patch
source = seafile-server@.service
source = seahub-preupgrade
source = create-default-conf-dir.patch
source = 0001-Revert-server-put-pids-folder-out-of-seafile-data.patch
source = libseafile.in.patch
- sha256sums = 486c4d8788dc26bd7558f1615ce99a79b54ca91c3d3cb4058fcbdf5cb9c59214
+ sha256sums = 0de96a7e2a45b5207480ec729f14d5b09d98d1c613807b0f190cfa2851e8b8b1
sha256sums = 876e67526fabf83bfeb5ff50f05b2f4725f3d9bf784025707b67022a1a311f20
sha256sums = ae1ed38f94304d27e4ef1ca66e15d544f99681c1e743c510c54d4a112f050421
sha256sums = 2a1e079cbea3543f356e6e9571f3d7d2a4b0ab75131ee417115d738ea191c4fb
@@ -36,6 +36,7 @@ pkgname = seafile-server
pkgdesc = Seafile server components, without seahub
install = seafile-server.install
depends = seafile-shared
+ depends = wget
depends = python2-mako
depends = python2-dateutil
depends = python2-webpy
@@ -43,9 +44,11 @@ pkgname = seafile-server
depends = python2-virtualenv
depends = python2-flup
depends = python2-six
+ depends = python2-chardet
+ depends = python2-simplejson
depends = libevhtp-seafile
depends = git
- conflicts = seafile-shared<5.0.4
+ conflicts = seafile-shared<5.0.5
options = !libtool
options = !emptydirs
@@ -53,11 +56,11 @@ pkgname = seafile-client-cli
pkgdesc = Seafile cli client
depends = seafile-shared
depends = libevent
- conflicts = seafile-shared<5.0.4
+ conflicts = seafile-shared<5.0.5
pkgname = seafile-shared
pkgdesc = Shared components of Seafile (seafile-daemon, libseafile, python bindings, manuals)
depends = ccnet
depends = fuse
- conflicts = ccnet<5.0.4
+ conflicts = ccnet<5.0.5
diff --git a/PKGBUILD b/PKGBUILD
index e39ad43481b1..c5989854f4a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Aaron Lindsay <aaron@aclindsay.com>
pkgname=('seafile-server' 'seafile-client-cli' 'seafile-shared')
-pkgver=5.0.4
-pkgrel=4
+pkgver=5.0.5
+pkgrel=1
pkgdesc="Seafile is an online file storage and collaboration tool"
arch=('i686' 'x86_64' 'armv7h' 'armv6h')
url="https://github.com/haiwen/seafile/"
@@ -18,7 +18,7 @@ source=("seafile-server-${pkgver}.tar.gz::https://github.com/haiwen/seafile/arch
"create-default-conf-dir.patch"
"0001-Revert-server-put-pids-folder-out-of-seafile-data.patch"
"libseafile.in.patch")
-sha256sums=('486c4d8788dc26bd7558f1615ce99a79b54ca91c3d3cb4058fcbdf5cb9c59214'
+sha256sums=('0de96a7e2a45b5207480ec729f14d5b09d98d1c613807b0f190cfa2851e8b8b1'
'876e67526fabf83bfeb5ff50f05b2f4725f3d9bf784025707b67022a1a311f20'
'ae1ed38f94304d27e4ef1ca66e15d544f99681c1e743c510c54d4a112f050421'
'2a1e079cbea3543f356e6e9571f3d7d2a4b0ab75131ee417115d738ea191c4fb'
@@ -88,10 +88,10 @@ package_seafile-shared() {
}
package_seafile-server() {
- depends=("seafile-shared"
+ depends=("seafile-shared" "wget"
"python2-mako" "python2-dateutil" "python2-webpy" "python2-pip"
- "python2-virtualenv" "python2-flup" "python2-six"
- "libevhtp-seafile" "git")
+ "python2-virtualenv" "python2-flup" "python2-six" "python2-chardet"
+ "python2-simplejson" "libevhtp-seafile" "git")
conflicts=("seafile-shared<${pkgver}")
options=('!libtool' '!emptydirs')
install=seafile-server.install
diff --git a/seafile-server.install b/seafile-server.install
index 7fcb753cf4ed..d1e2082ee1f7 100755
--- a/seafile-server.install
+++ b/seafile-server.install
@@ -3,20 +3,16 @@ pre_install() {
virtualenv2 --relocatable /usr/lib/seafile/seafileenv
source /usr/lib/seafile/seafileenv/bin/activate
- pip install chardet
- pip install simplejson
- pip install six
- pip install python-dateutil
- pip install django-pipeline
- pip install "Django>=1.5.8,<1.6"
- pip install http://effbot.org/media/downloads/PIL-1.1.7.tar.gz
- pip install "https://github.com/djblets/djblets/archive/release-0.6.14.zip#egg=Djblets"
- pip install "Pillow>=2.6.1,<3.0.0"
- pip install gunicorn
- pip install "django-compressor==1.4"
- pip install "django-statici18n==1.1.2"
- pip install "git+git://github.com/haiwen/django-constance.git@bde7f7cdfd0ed1631a6817fd4cd76f37bf54fe35#egg=django-constance[database]"
- pip install "openpyxl==2.3.0"
+ pip2 install gunicorn
+ pip2 install "Django>=1.5.8,<1.6"
+ pip2 install django-pipeline
+ pip2 install http://effbot.org/media/downloads/PIL-1.1.7.tar.gz
+ pip2 install "https://github.com/djblets/djblets/archive/release-0.6.14.zip#egg=Djblets"
+ pip2 install "Pillow>=2.6.1,<3.0.0"
+ pip2 install "django-compressor==1.4"
+ pip2 install "django-statici18n==1.1.2"
+ pip2 install "git+git://github.com/haiwen/django-constance.git@bde7f7cdfd0ed1631a6817fd4cd76f37bf54fe35#egg=django-constance[database]"
+ pip2 install "openpyxl==2.3.0"
deactivate
}