summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2017-05-22 10:46:20 +0200
committereolianoe2017-05-22 10:46:20 +0200
commit198c99c17d348d1e2bd618e560baf72cee4019b6 (patch)
tree969a0147dac11875fc92768bc043cfe936767c5b
parent973d944fe9795545c6ef1394511d2b6313d80a0e (diff)
downloadaur-198c99c17d348d1e2bd618e560baf72cee4019b6.tar.gz
update deps
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
-rwxr-xr-xseafile-server.install17
3 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b74ca938970..e9d0d3233306 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun May 14 14:19:46 UTC 2017
+# Mon May 22 08:46:16 UTC 2017
pkgbase = seafile-server
pkgdesc = Seafile is an online file storage and collaboration tool
pkgver = 6.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/haiwen/seafile-server
install = seafile-server.install
arch = i686
@@ -31,6 +31,7 @@ pkgbase = seafile-server
depends = python2-simplejson
depends = libevhtp-seafile
depends = git
+ depends = ffmpeg
optdepends = libmariadbclient: mysql server support
source = seafile-server-6.1.0-server.tar.gz::https://github.com/haiwen/seafile-server/archive/v6.1.0-server.tar.gz
source = seafile-admin_virtualenv.patch
diff --git a/PKGBUILD b/PKGBUILD
index b8f55b95b8d1..94ffa12eb801 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=seafile-server
pkgver=6.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Seafile is an online file storage and collaboration tool"
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/haiwen/${pkgname}"
@@ -13,7 +13,8 @@ makedepends=("vala" "intltool")
depends=("seafile" "wget" "sqlite" "fuse" "ccnet-server" "libarchive"
"python2-mako" "python2-dateutil" "python2-webpy" "python2-pip"
"python2-virtualenv" "python2-flup" "python2-six" "python2-chardet"
- "python2-simplejson" "libevhtp-seafile" "git")
+ "python2-simplejson" "libevhtp-seafile" "git"
+ "ffmpeg")
source=("${pkgname}-${pkgver}-server.tar.gz::${url}/archive/v${pkgver}-server.tar.gz"
"seafile-admin_virtualenv.patch"
"seafile-server@.service"
diff --git a/seafile-server.install b/seafile-server.install
index 752be34c89ff..19ded1702b79 100755
--- a/seafile-server.install
+++ b/seafile-server.install
@@ -4,16 +4,19 @@ pre_install() {
virtualenv2 --relocatable /usr/lib/seafile/seafileenv
source /usr/lib/seafile/seafileenv/bin/activate
- pip2 install "Django==1.8.10"
- pip2 install "django-statici18n==1.1.2"
+ pip2 install "python-memcached==1.57"
+ pip2 install "Pillow"
+ pip2 install "moviepy"
+ pip2 install "Django==1.8.18"
pip2 install "django-compressor==1.4"
- pip2 install "git+git://github.com/haiwen/django-constance.git@bde7f7cdfd0ed1631a6817fd4cd76f37bf54fe35#egg=django-constance[database]"
+ pip2 install "django-post-office==2.0.3"
+ pip2 install "django-statici18n==1.1.2"
+ pip2 install "djangorestframework==3.3.1"
+ pip2 install "git+git://github.com/haiwen/django-constance.git@751f7f8b60651a2828e4a535a47fc05b907883da#egg=django-constance[database]"
pip2 install "openpyxl==2.3.0"
pip2 install "pytz==2015.7"
- pip2 install "djangorestframework==3.3.1"
- pip2 install "django-post-office==2.0.3"
- pip2 install "Pillow>=2.6.1,<3.0.0"
- pip2 install "python-memcached==1.57"
+ pip2 install "django-formtools"
+ pip2 install "qrcode"
pip2 install gunicorn
deactivate
}