summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Vybíhal2018-08-06 12:15:05 +0200
committerJosef Vybíhal2018-08-06 12:15:05 +0200
commit6f1193d5735ddd0460dd88ddd9dc34bba95e1a9a (patch)
treeb7bf873ddae5120d2c207eccbec08a3a1bdef12a
downloadaur-6f1193d5735ddd0460dd88ddd9dc34bba95e1a9a.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--0001-LDAP-source-Fix-non-debug-build.patch89
-rw-r--r--PKGBUILD47
3 files changed, 164 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57391a73970f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = seahorse-git
+ pkgdesc = GNOME application for managing PGP keys. Master branch.
+ pkgver = 3.29.90+10+g9496a0d1
+ pkgrel = 3
+ url = https://wiki.gnome.org/Apps/Seahorse
+ arch = x86_64
+ license = GPL
+ makedepends = libldap
+ makedepends = yelp-tools
+ makedepends = gobject-introspection
+ makedepends = vala
+ makedepends = git
+ makedepends = meson
+ depends = gtk3
+ depends = gcr
+ depends = libsecret
+ depends = libsoup
+ depends = gpgme
+ depends = gnome-keyring
+ provides = x11-ssh-askpass
+ conflicts = seahorse
+ source = git+https://gitlab.gnome.org/GNOME/seahorse.git
+ source = 0001-LDAP-source-Fix-non-debug-build.patch
+ sha256sums = SKIP
+ sha256sums = 7c45e55f9d98510e1f9305af71d9a11d66fd15100ed29239493c94d591eb9e98
+
+pkgname = seahorse-git
+
diff --git a/0001-LDAP-source-Fix-non-debug-build.patch b/0001-LDAP-source-Fix-non-debug-build.patch
new file mode 100644
index 000000000000..882985b8d91f
--- /dev/null
+++ b/0001-LDAP-source-Fix-non-debug-build.patch
@@ -0,0 +1,89 @@
+From b82bf06c54f648e2d795b567a5d824f40c27614f Mon Sep 17 00:00:00 2001
+Message-Id: <b82bf06c54f648e2d795b567a5d824f40c27614f.1521136846.git.jan.steffens@gmail.com>
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Thu, 15 Mar 2018 18:57:47 +0100
+Subject: [PATCH] LDAP source: Fix non-debug build
+
+In non-debug builds, WITH_DEBUG is defined but set to 0.
+
+Simplify the use of dump_ldap_entry by making it do nothing in non-debug
+builds.
+---
+ pgp/seahorse-ldap-source.c | 12 ++----------
+ 1 file changed, 2 insertions(+), 10 deletions(-)
+
+diff --git a/pgp/seahorse-ldap-source.c b/pgp/seahorse-ldap-source.c
+index 4819c918..0dd72446 100644
+--- a/pgp/seahorse-ldap-source.c
++++ b/pgp/seahorse-ldap-source.c
+@@ -125,35 +125,33 @@ get_ldap_values (LDAP *ld, LDAPMessage *entry, const char *attribute)
+ return (gchar**)g_array_free (array, FALSE);
+ }
+
+-#if WITH_DEBUG
+-
+ static void
+ dump_ldap_entry (LDAP *ld, LDAPMessage *res)
+ {
++#if WITH_DEBUG
+ BerElement *pos;
+ gchar **values;
+ gchar **v;
+ char *t;
+
+ t = ldap_get_dn (ld, res);
+ g_debug ("dn: %s\n", t);
+ ldap_memfree (t);
+
+ for (t = ldap_first_attribute (ld, res, &pos); t;
+ t = ldap_next_attribute (ld, res, pos)) {
+
+ values = get_ldap_values (ld, res, t);
+ for (v = values; *v; v++)
+ g_debug ("%s: %s\n", t, *v);
+
+ g_strfreev (values);
+ ldap_memfree (t);
+ }
+
+ ber_free (pos, 0);
+-}
+-
+ #endif /* WITH_DEBUG */
++}
+
+ static GQuark
+ get_ldap_error_domain ()
+@@ -474,9 +472,7 @@ on_connect_server_info_completed (LDAPMessage *result,
+ if (type == LDAP_RES_SEARCH_ENTRY) {
+
+ g_debug ("Server Info Result");
+-#ifdef WITH_DEBUG
+ dump_ldap_entry (closure->ldap, result);
+-#endif
+
+ /* NOTE: When adding attributes here make sure to add them to kServerAttributes */
+ sinfo = g_new0 (LDAPServerInfo, 1);
+@@ -867,9 +863,7 @@ on_search_search_completed (LDAPMessage *result,
+ /* An LDAP entry */
+ if (type == LDAP_RES_SEARCH_ENTRY) {
+ g_debug ("Retrieved Key Entry");
+-#ifdef WITH_DEBUG
+ dump_ldap_entry (closure->ldap, result);
+-#endif
+
+ search_parse_key_from_ldap_entry (self, closure->results,
+ closure->ldap, result);
+@@ -1238,9 +1232,7 @@ on_export_search_completed (LDAPMessage *result,
+ if (type == LDAP_RES_SEARCH_ENTRY) {
+
+ g_debug ("Server Info Result");
+-#ifdef WITH_DEBUG
+ dump_ldap_entry (closure->ldap, result);
+-#endif
+
+ key = get_string_attribute (closure->ldap, result, sinfo->key_attr);
+
+--
+2.16.2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edd6907d69c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Josef Vybíhal <josef.vybihal@gmail.com>
+# Note: Package builds on PKGBUILD from ABS, provides latest version from
+# git master branch of Seahorse.
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: Michel Brabants <michel.linux@tiscali.be>
+pkgname=seahorse-git
+pkgver=3.29.90+10+g9496a0d1
+pkgrel=3
+pkgdesc="GNOME application for managing PGP keys. Master branch."
+url="https://wiki.gnome.org/Apps/Seahorse"
+arch=(x86_64)
+license=(GPL)
+depends=(gtk3 gcr libsecret libsoup gpgme gnome-keyring)
+conflicts=('seahorse')
+provides=('seahorse')
+makedepends=(libldap yelp-tools gobject-introspection vala git meson)
+provides=(x11-ssh-askpass)
+#_commit=9496a0d19efd681850dbfe38012c5db4709f591e # master
+source=("git+https://gitlab.gnome.org/GNOME/seahorse.git"
+ 0001-LDAP-source-Fix-non-debug-build.patch)
+sha256sums=('SKIP'
+ '7c45e55f9d98510e1f9305af71d9a11d66fd15100ed29239493c94d591eb9e98')
+
+pkgver() {
+ cd seahorse/
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd seahorse/
+ patch -Np1 -i ../0001-LDAP-source-Fix-non-debug-build.patch
+}
+
+build() {
+ arch-meson seahorse build
+ ninja -C build
+}
+
+check() {
+ cd build
+ meson test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}