summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRalph Plawetzki2022-11-15 08:10:57 +0100
committerRalph Plawetzki2022-11-15 08:13:59 +0100
commit02ddf3e90bb3afe857fd729ecfc20927516a636a (patch)
treeb86091a1f90747bf706b520698681885804c2c2c
parent6d7baec69466b8f180a5317961c93a658658f545 (diff)
downloadaur-02ddf3e90bb3afe857fd729ecfc20927516a636a.tar.gz
Pull changs from seahorse-nautilus 1:3.11.92+r96+g0fd324c-1
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f0a1da4c58b..8c8c36200dea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
# Maintainer: Ralph Plawetzki <ralph@purejava.org>
pkgname=seahorse-nautilus-ext
-pkgver=3.11.92+57+g390364d
+pkgver=3.11.92+r96+g0fd324c
pkgrel=1
+epoch=1
pkgdesc="PGP encryption and signing for nautilus with configurable extension for encrypted files"
-arch=(x86_64)
url="https://gitlab.gnome.org/purejava/seahorse-nautilus/tree/encrypt-ext-conf"
+arch=(x86_64)
license=(GPL)
-depends=(libcryptui nautilus libgnome-keyring)
+depends=(libnautilus-extension gtk3 gcr libcryptui libnotify)
makedepends=(meson git)
provides=(seahorse-nautilus)
conflicts=(seahorse-nautilus)
-_commit=390364db3bb09d7f6e07e3de90c872112584442a # master
-source=($pkgname::"git+https://gitlab.gnome.org/GNOME/seahorse-nautilus.git#commit=$_commit")
+options=(debug)
+_commit=0fd324c191565bff76ca45a01b2da14b4ab7b3bd # master
+source=("git+$url.git#commit=$_commit")
sha256sums=('SKIP')
pkgver() {
cd $pkgname
- git describe --tags | sed 's/-/+/g'
+ git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
}
prepare() {
@@ -27,9 +29,13 @@ prepare() {
build() {
arch-meson $pkgname build
- ninja -C build
+ meson compile -C build
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ depends+=(libnautilus-extension.so)
+
+ meson install -C build --destdir "$pkgdir"
}
+
+# vim:set sw=2 sts=-1 et: