summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRalph Plawetzki2022-11-15 08:44:48 +0100
committerRalph Plawetzki2022-11-15 08:44:48 +0100
commit80e097611f994ed1818871fe66e3177334541518 (patch)
treea3f578d88ecde394cca92ecba88cfa7416b91a27
parent02ddf3e90bb3afe857fd729ecfc20927516a636a (diff)
downloadaur-80e097611f994ed1818871fe66e3177334541518.tar.gz
Fix build errors
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD8
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d946f9baac9e..9e69ebd5a4e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,28 @@
pkgbase = seahorse-nautilus-ext
pkgdesc = PGP encryption and signing for nautilus with configurable extension for encrypted files
- pkgver = 3.11.92+57+g390364d
+ pkgver = 3.11.92+r96+g0fd324c
pkgrel = 1
- url = https://gitlab.gnome.org/purejava/seahorse-nautilus/tree/encrypt-ext-conf
+ epoch = 1
+ url = https://gitlab.gnome.org/GNOME/seahorse-nautilus
arch = x86_64
license = GPL
makedepends = meson
makedepends = git
+ depends = libnautilus-extension
+ depends = gtk3
+ depends = gcr
depends = libcryptui
- depends = nautilus
- depends = libgnome-keyring
+ depends = libnotify
provides = seahorse-nautilus
conflicts = seahorse-nautilus
- source = seahorse-nautilus-ext::git+https://gitlab.gnome.org/GNOME/seahorse-nautilus.git#commit=390364db3bb09d7f6e07e3de90c872112584442a
+ options = debug
+ source = git+https://gitlab.gnome.org/GNOME/seahorse-nautilus.git#commit=0fd324c191565bff76ca45a01b2da14b4ab7b3bd
sha256sums = SKIP
pkgname = seahorse-nautilus-ext
-
+ depends = libnautilus-extension
+ depends = gtk3
+ depends = gcr
+ depends = libcryptui
+ depends = libnotify
+ depends = libnautilus-extension.so
diff --git a/PKGBUILD b/PKGBUILD
index 8c8c36200dea..c64a91be5aa0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgver=3.11.92+r96+g0fd324c
pkgrel=1
epoch=1
pkgdesc="PGP encryption and signing for nautilus with configurable extension for encrypted files"
-url="https://gitlab.gnome.org/purejava/seahorse-nautilus/tree/encrypt-ext-conf"
+url="https://gitlab.gnome.org/GNOME/seahorse-nautilus"
arch=(x86_64)
license=(GPL)
depends=(libnautilus-extension gtk3 gcr libcryptui libnotify)
@@ -18,17 +18,17 @@ source=("git+$url.git#commit=$_commit")
sha256sums=('SKIP')
pkgver() {
- cd $pkgname
+ cd seahorse-nautilus
git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
}
prepare() {
- cd $pkgname
+ cd seahorse-nautilus
git apply ../../0001-Make-file-extension-for-encrypted-files-configurable.patch
}
build() {
- arch-meson $pkgname build
+ arch-meson seahorse-nautilus build
meson compile -C build
}