summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2018-01-07 16:36:44 +0100
committereolianoe2018-01-07 16:36:44 +0100
commit4faa10fbcb5dacf6e58c9efc2b2f23764878114a (patch)
tree1c42ab6634d5edfd260b9f8c5fa7b6aa41551ab3
parent7bf95b1d4d339ad2607c113c4665f8af08f5c3f5 (diff)
downloadaur-4faa10fbcb5dacf6e58c9efc2b2f23764878114a.tar.gz
use more the virtualenv
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97e64eb82238..8594d8df22f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jan 5 19:38:03 UTC 2018
+# Sun Jan 7 15:36:21 UTC 2018
pkgbase = seahub
pkgdesc = The web end of seafile server
pkgver = 6.2.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/haiwen/seahub
install = seahub.install
arch = i686
@@ -12,12 +12,9 @@ pkgbase = seahub
arch = armv6h
arch = aarch64
license = Apache
- makedepends = python2-pip
depends = seafile-server
depends = python2-virtualenv
- depends = python2-django-pylibmc
- depends = python2-dateutil
- depends = python2-qrcode
+ depends = libmemcached
options = !strip
source = seahub-6.2.3-server.tar.gz::https://github.com/haiwen/seahub/archive/v6.2.3-server.tar.gz
source = seahub-preupgrade
diff --git a/PKGBUILD b/PKGBUILD
index cc73a3d33159..d94b61ebfe40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,12 @@
pkgname=seahub
pkgver=6.2.3
-pkgrel=2
+pkgrel=3
pkgdesc="The web end of seafile server"
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/haiwen/${pkgname}"
license=('Apache')
-depends=("seafile-server" "python2-virtualenv" "python2-django-pylibmc"
- 'python2-dateutil' 'python2-qrcode')
-makedepends=('python2-pip')
+depends=("seafile-server" "python2-virtualenv" 'libmemcached')
install="${pkgname}.install"
source=("${pkgname}-${pkgver}-server.tar.gz::${url}/archive/v${pkgver}-server.tar.gz"
"seahub-preupgrade")
@@ -39,12 +37,12 @@ package() {
"${pkgdir}/usr/bin/seahub-preupgrade"
# Create private virtualenv
- virtualenv2 --system-site-packages "${pkgdir}/usr/lib/seafile/seafileenv"
+ virtualenv2 --no-wheel --system-site-packages "${pkgdir}/usr/lib/seafile/seafileenv"
source "${pkgdir}/usr/lib/seafile/seafileenv/bin/activate"
pip2 --isolated install --no-compile \
-r "${srcdir}/${pkgname}-${pkgver}-server/requirements.txt"
pip2 --isolated install --no-compile \
- gunicorn
+ gunicorn pylibmc django-pylibmc
deactivate
virtualenv2 --relocatable "${pkgdir}/usr/lib/seafile/seafileenv"