summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoffrey Darcq2018-06-03 11:40:37 +0200
committerJoffrey Darcq2018-06-03 11:40:37 +0200
commitea886b97eec505d60b96e00e89c7668e781ed3b6 (patch)
tree20d5f55f60b77bfc78f70366f8919a0e90c956ee
parent4236e3b6bbc22714eb79373dc56d55f92ba769cf (diff)
downloadaur-ea886b97eec505d60b96e00e89c7668e781ed3b6.tar.gz
updpkg: 6.3.0
-rw-r--r--.SRCINFO10
-rw-r--r--ChangeLog5
-rw-r--r--PKGBUILD37
3 files changed, 32 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26d31228ec49..dba0fbbcd514 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = seahub
pkgdesc = The web frontend for seafile server
- pkgver = 6.2.5
- pkgrel = 6
+ pkgver = 6.3.0
+ pkgrel = 1
url = https://github.com/haiwen/seahub
changelog = ChangeLog
arch = i686
@@ -12,7 +12,7 @@ pkgbase = seahub
license = custom:Apache PSF MIT BSD GPL
makedepends = python2-virtualenv
makedepends = git
- depends = seafile-server=6.2.5
+ depends = seafile-server>=6.3.0
depends = libmemcached
depends = freetype2
depends = openjpeg2
@@ -20,8 +20,8 @@ pkgbase = seahub
optdepends = memcached: For better caching performance
optdepends = ffmpeg: For video thumbnails
options = !strip
- source = seahub-6.2.5-server.tar.gz::https://github.com/haiwen/seahub/archive/v6.2.5-server.tar.gz
- sha256sums = 80a7a1cadde8e8e570bdc454bc4a4902ebcace97b347f9eef701b5ab02742039
+ source = seahub-6.3.0-server.tar.gz::https://github.com/haiwen/seahub/archive/v6.3.0-server.tar.gz
+ sha256sums = 89b52185ecf6a90417b4c52b4e24fb7af941996b7a9f92875dfc00967719627f
pkgname = seahub
diff --git a/ChangeLog b/ChangeLog
index 95990e3080d1..160fd318b87a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2018-06-03 Joffrey <j-off@live.fr>
+ * Version: 6.3.0-1
+
+ * PKGBUILD: fix future depends '>=' (for now use 'pacman -Udd pkg')
+
2018-02-26 Joffrey <j-off@live.fr>
* Version: 6.2.5-6
diff --git a/PKGBUILD b/PKGBUILD
index ba6e4c9d6dce..43372d490bc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,32 +4,26 @@
# Contributor: Aaron Lindsay <aaron@aclindsay.com>
pkgname='seahub'
-pkgver=6.2.5
-pkgrel=6
+pkgver=6.3.0
+pkgrel=1
pkgdesc='The web frontend for seafile server'
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/haiwen/${pkgname}"
license=('custom:Apache PSF MIT BSD GPL')
-depends=("seafile-server=${pkgver}" 'libmemcached' 'freetype2' 'openjpeg2')
+depends=("seafile-server>=${pkgver}" 'libmemcached' 'freetype2' 'openjpeg2')
optdepends=('mariadb: For use MySQL databases'
'memcached: For better caching performance'
- 'ffmpeg: For video thumbnails')
+ 'ffmpeg: For video thumbnails'
+)
makedepends=('python2-virtualenv' 'git')
changelog="ChangeLog"
source=("${pkgname}-${pkgver}-server.tar.gz::${url}/archive/v${pkgver}-server.tar.gz")
-sha256sums=('80a7a1cadde8e8e570bdc454bc4a4902ebcace97b347f9eef701b5ab02742039')
+sha256sums=('89b52185ecf6a90417b4c52b4e24fb7af941996b7a9f92875dfc00967719627f')
options=("!strip")
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}-server"
- # Remove useless files and directories
- rm -rf './'{*test*,*sh*,CONTRIBUTORS,HACKING,Makefile,README.*,pylintrc*}
-
- # Use python lib seahub interpreter for all scripts
- grep -s -l -r '#!/usr/bin/env python' "./" \
- | xargs sed -i -e '1 s|#!/usr/bin/env python|#!/usr/lib/seahub/bin/python2|'
-
# Add python utils modules to requirements.txt
{
echo 'flup' # WSGI support
@@ -38,8 +32,21 @@ prepare() {
echo 'django-pylibmc' # Memcached support
} >> "./requirements.txt"
- # Prepare License
- cat './LICENSE-'* >> './LICENSE.txt' && rm -f './LICENSE-'*
+ # Prepare License
+ {
+ cat './LICENSE.txt'
+ cat './LICENSE-'*
+ } >> './LICENSE'
+
+ # Remove useless files and directories
+ rm -rf \
+ './CONTRIBUTORS' './HACKING' './Makefile' \
+ './'{*test*,*dev*,*sh*,README*,pylintrc*,LICENSE[.-]*} \
+ "$(find . -name \*.pyc)"
+
+ # Use python lib seahub interpreter for all scripts
+ grep -s -l -r '#!/usr/bin/env python' "./" \
+ | xargs sed -i -e '1 s|#!/usr/bin/env python|#!/usr/lib/seahub/bin/python2|'
}
build() {
@@ -59,7 +66,7 @@ package() {
install -dm755 "${pkgdir}/usr/share/seafile-server/seahub"
cp -r -p "./"* "${pkgdir}/usr/share/seafile-server/seahub/"
- install -Dm644 './LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 './LICENSE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# Create VirtualEnv
venv="${pkgdir}/usr/lib/seahub"