summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2021-01-28 12:06:13 +0100
committerAlexander F. Rødseth2021-01-28 12:06:13 +0100
commitdf8be9c795ee305ea5c351d9792c1a5907cf4081 (patch)
tree84e036ab46d07bb342cdba4526a145c7299c7ecb
downloadaur-df8be9c795ee305ea5c351d9792c1a5907cf4081.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84f1b8e0673e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = sealion
+ pkgdesc = Be reminded of daily events, such as lunch
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/xyproto/sealion
+ arch = any
+ license = MIT
+ depends = python
+ optdepends = bash: bash support
+ optdepends = fish: fish support
+ optdepends = zsh: zsh support
+ source = git+https://github.com/xyproto/sealion#commit=4491fe57ab795c0b6cebf39d01d00cd63e917508
+ sha256sums = SKIP
+
+pkgname = sealion
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2bd5dbaa2aac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=sealion
+pkgver=2.0.1
+pkgrel=1
+pkgdesc='Be reminded of daily events, such as lunch'
+arch=(any)
+url='https://github.com/xyproto/sealion'
+license=(MIT)
+depends=(python)
+optdepends=('bash: bash support'
+ 'fish: fish support'
+ 'zsh: zsh support')
+source=("git+$url#commit=4491fe57ab795c0b6cebf39d01d00cd63e917508") # tag: v2.0.1
+sha256sums=(SKIP)
+
+package() {
+ cd $pkgname
+ DESTDIR="$pkgdir" make install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/sealion/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: